[Nut-upsuser] Device not supported?

Ambrogio Coletti ambrojohn at gmail.com
Wed Jul 5 21:34:49 UTC 2017

>From section 4.23 of the Developer Guide:

"There are a few USB UPS devices that are not HID devices. These devices
typically implement some version of the manufacturer’s serial protocol over
USB (which is a really dumb idea, by the way). An example is the Tripplite
USB. Such devices are *not* supported by the usbhid-ups driver, and are not
covered in this document."

I guess that applies to me?

On Wed, Jul 5, 2017 at 3:19 PM Ambrogio Coletti <ambrojohn at gmail.com> wrote:

> I've eventually installed Manuel's packages (nut and nut-client).
> When I run the driver as root (for my tripplite ups) I get:
> /usr/sbin/upsdrvctl start
> Network UPS Tools - Generic HID driver 0.42 (v2.7.4-418-gb1314c62.7.4.1)
> USB communication driver (libusb 0.1) 0.33
> writepid: fopen /var/run/nut/usbhid-ups-trippliteups.pid: Permission denied
> Can't claim USB device [09ae:1330]: could not detach kernel driver from
> interface 0: Operation not permitted
> Driver failed to start (exit status=1)
> And I had to create manually /var/run/nut.
> What is the problem there?
> On Fri, Jun 23, 2017 at 8:27 PM Manuel Wolfshant <wolfy at nobugconsulting.ro>
> wrote:
>> On 06/24/2017 04:52 AM, Charles Lepple wrote:
>> > On Jun 23, 2017, at 5:50 PM, Ambrogio Coletti <ambrojohn at gmail.com>
>> wrote:
>> >> "This TrippLite device (09ae:1330) is not (or perhaps not yet)
>> supported by usbhid-ups. [...]"
>> >> but my device (SU2200RTXLCD2U) is supported, as clearly state here.
>> > No, the HCL also mentions "protocol 4001". For Tripp-Lite, a USB PID
>> other than 0001 is generally the protocol number. So your SU2200* model is
>> different.
>> >
>> > https://github.com/networkupstools/nut/issues/64
>> >
>> >> Then I thought I needed the last src code (2.7.4), hence I built it
>> for my machine, but when I run it by:
>> >> /usr/local/ups/sbin/upsdrvctl start
>> > The Protocol 1330 support was added after 2.7.4 was released. You might
>> be able to use a 2.7.4 tarball with "productid = 1330" in ups.conf, but
>> voltages might be off by a factor of 10. You will also need to adjust the
>> udev files manually to fix /dev/bus/usb permissions.
>> >
>> > If you do choose to build using the latest source code from Git, be
>> aware that you will need more tools, as specified in the Developer Guide:
>> http://networkupstools.org/docs/developer-guide.chunked/ar01s03.html#building
>> >
>> > It may be easier to use the 2.7.4 tarball, and add the patch which
>> introduces Protocol 1330 support to the RPM spec file:
>> https://github.com/networkupstools/nut/commit/4eff5b7068e9873ce11b5a296f403e8cdf0e3580
>> I've uploaded to http://wolfy.fedorapeople.org/nut a new set of packages
>> based on the latest source code from git. Unfortunately they do not
>> include any man pages, I did not have time to find a workaround for the
>> hard requirement of newer versions for the tools used by the build
>> process to create the man pages. I will fix that in a later set of
>> packages.
>> _______________________________________________
>> Nut-upsuser mailing list
>> Nut-upsuser at lists.alioth.debian.org
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20170705/41db7bc9/attachment.html>

More information about the Nut-upsuser mailing list