[Nut-upsuser] [HCL] Cyber Power Systems CP1500AVRLCDa supported by usbhid-ups

Mike the.lists at mgm51.com
Sat Jun 3 18:21:57 UTC 2017

On 5/30/2017 10:47 PM, Charles Lepple wrote:
> On May 22, 2017, at 11:13 AM, Mike <the.lists at mgm51.com> wrote:
>> On 5/21/2017 10:39 AM, Charles Lepple wrote:

> Even though the CPS sub-driver has been written already, I would like to take a look at the raw "explore" mode output:
> http://new.networkupstools.org/docs/developer-guide.chunked/ar01s04.html#_writing_a_subdriver

When I ran:

drivers/usbhid-ups -DD -u root -x explore -x vendorid=0764 auto

it balked at "auto":

Network UPS Tools - Generic HID driver 0.41 (2.7.4)
USB communication driver 0.33
   0.000000     Error: too many non-option arguments. Try -h for help.

so I added a -a parameter to point to the ups name configured in
ups.conf, and that worked.  The output from that command is zipped and

> If it were the input voltage, I would recommend experimenting with a variac, but you are probably not going to see much of a range on the output before the buck/boost circuits kick in. So it's still an option, but it might not be worth the trouble for an UPS in service (or if you don't have a variac handy).

Here's the results of the varying voltage tests:

input   output       UPS        output.voltage  input.voltage
to UPS  from UPS     display
119.9   120.4        119            136.0          120.0
115.2   115.6        114            138.0          114.0
127.3   128.0        127            136.0          127.0
135.5   136.4        135            136.0          135.0
100.4   100.5        100            140.0          100.0
 94.9   105.1         95            137.0           96.0
120.7   121.1        120            142.0          118.0
140.8   122.8        139            136.0          139.0
121.7   122.1        121            136.0          120.0


1) the input to UPS was measured by a Kill-A-Watt device, the output
from UPS was measured by a HP 974a DVM.  Prior to these tests, I ran
them from the same source, and they tracked pretty well, with the 974a
usually about 0.5 volts higher than the Kill-A-Watt.  For the purpose of
this test, I figured that would be OK.

2) output.voltage and input.voltage were from the upsc command

3) the readings were taken about 30 to 45 seconds apart.  That's how
long it took me to set a new voltage on the Powerstat.

4) when I went down to 95 volts, the "AVR" kicked in to boost the
voltage without going to battery.  This was indicated by a "click" from
the UPS and an indication on the UPS display.

5) When I went up to 140 volts, the UPS switched over to batteries.

Hope this helps.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ups-test.zip
Type: application/octet-stream
Size: 2576 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20170603/fad12f74/attachment.obj>

More information about the Nut-upsuser mailing list