[Nut-upsuser] Device not supported?

Manuel Wolfshant wolfy at nobugconsulting.ro
Fri Jun 23 23:22:47 UTC 2017

On 06/24/2017 12:50 AM, Ambrogio Coletti wrote:
> Hello
> I am trying to install the NUT on CentOS 6 (2.6.32-696.3.1.el6.x86_64).
> First I installed it using:
> yum install epel-release --enablerepo=extras
> yum install nut
> And when I run it by:
> sbin/upsdrvctl start
> (that's where it installed it using the package)
> I had the following message:
> "This TrippLite device (09ae:1330) is not (or perhaps not yet) 
> supported by usbhid-ups. [...]"
> but my device (SU2200RTXLCD2U) is supported, as clearly state here 
> <http://networkupstools.org/stable-hcl.html>.
> Then I thought I needed the last src code (2.7.4), hence I built it 
> for my machine, but when I run it by:
> /usr/local/ups/sbin/upsdrvctl start
> I had, in order, this message
> "writepid: fopen /var/state/ups/usbhid-ups-trippliteups.pid: 
> Permission denied"
the permissions used by the driver are not those set on the directory 
where it tries to write
for testing purposes you could try to run it as root
in order to avoid conflicts, if you did not already do that, please also 
remove the package installed from EPEL prior to testing.

> and...the same message above about the not supported device!
> What's wrong in there?
the fact that on a package-managed distribution you are using 
self-compiled applications, without using the correct settings at 
compile time :).
If you are not willing to use the packages I provide, at least take 
inspiration from the spec file included in 
https://wolfy.fedorapeople.org/nut/nut-2.7.4-4.el6.wolfy.1.src.rpm ( the 
%build and %install sections ). Although you'd better rebuild that 
src.rpm if you are afraid to use the binaries directly.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20170624/10112e02/attachment.html>

More information about the Nut-upsuser mailing list