[Nut-upsuser] nut-scanner, SNMPv3, APC UPS not chatting

Lee Damon nomad at ee.washington.edu
Tue Apr 28 21:28:02 BST 2020

I'm trying to get SNMPv3 management working for an APC AP9617 card. It is
newly refurbed, running sumx v3.7.2 and aos v3.7.3.

In the SNMPv3 user profiles section I have (I don't care about the password
leaking, it's temporary):

  User Name: nut
  Authentication Passphrase: NutScan at Password43LongerWord
  Privacy Passphrase: NutScan at Password43LongerWord
  Authentication protocol: MD5 (only option other than none)
  Privacy Protocol: DES (only option other than none)

In access control I've enabled user nut.

However, when I try to use nut-scanner on it:
$ nut-scanner -S -s apcups --secLevel authPriv --secName nut --authProtocol
MD5 --authPassword NutScan at Password43LongerWord --privProtocol DES
--privPassword NutScan at Password43LongerWord
Scanning SNMP bus.
Error: unknown authtypeError generating Ku from authentication pass phrase

snmpwalk gives a different error:
$ snmpwalk -v 3 -u nut apcups -x DES -X NutScan at Password43LongerWord -a MD5
-A NutScan at Password43LongerWord
snmpwalk: Decryption error

I've tried it with all lowercase, mixed case, mixed case + numbers, and the
one you see here. I've also used an 18 character password. All get exactly
the same result.

I've tried setting the privacy protocol to none and leaving off the -x & -X
flags, still get the same error messages.

I see a note in APC's documentation that it may take some time for the card
to be ready to talk SNMPv3. I've waited as long as 15 minutes with no
change in behavior.

snmpwalk and nut-scanner are both happy SNMPv1 -c public.

Can anyone tell me, please, what trivially obvious thing am I missing?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200428/c461b613/attachment.html>

More information about the Nut-upsuser mailing list