[pymvpa] pymvpa installation problem... nifti not found

Yaroslav Halchenko debian at onerussian.com
Fri Oct 29 17:54:27 UTC 2010

On Fri, 29 Oct 2010, tbeck at artsci.wustl.edu wrote:
> python -c 'import nifti' gave me the same error:
> Import Error: No module named nifti

so, there is no nifti for this version/flavor of python you are using by
default ;)

> can you tell from this output what may have
> gone wrong? 
I bet it is exactly what I feared:

 P.S. Common problem on OSX is the hell of mixes of different pythons
 and corresponding modules installed via variety of methods (local,
 macports, etc) since there is no uniform one "out of the box"
 installation mechanism, i.e. like on Debian ;-)  thus for the best
 experience we just advice users to use

> When I ran print mvpa.wtf(), I noticed a bunch of the externals don't seem
> to have installed properly (see below).  Is there a command to install
> these individually manually? 

get sources and follow each package installation instructions, which
most of the time something like

python setup.py install

or once again -- forget about all this mess and use virtual machine with
Debian and enjoy the paradise ;-)

=------------------------------   /v\  ----------------------------=
Keep in touch                    // \\     (yoh@|www.)onerussian.com
Yaroslav Halchenko              /(   )\               ICQ#: 60653192
                   Linux User    ^^-^^    [175555]

More information about the Pkg-ExpPsy-PyMVPA mailing list