[pymvpa] py27-pymvpa: build error

Yun-Ta Tsai andytsai at mit.edu
Wed Jun 22 20:42:50 UTC 2016

when i tried cloning git with your recipe, it showed this:

Cloning into 'PyMVPA'...
fatal: unable to connect to github.com:
github.com[0:]: errno=Operation timed out

however, when I checked macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pymvpa
I find a pymvpa folder that seems to have the files. I attached the screenshot.

however when i try to import mvpa2 into python it shows that no such module exists. where do i put the MVPA folder containing all the files in order for python to be able to import?

thanks in advance!

From: Pkg-ExpPsy-PyMVPA [pkg-exppsy-pymvpa-bounces+andytsai=mit.edu at lists.alioth.debian.org] on behalf of David Soto [d.soto.b at gmail.com]
Sent: Wednesday, June 22, 2016 4:25 PM
To: Development and support of PyMVPA
Subject: Re: [pymvpa] py27-pymvpa: build error

Hi, I had trouble with macports, but was able to install all dependencias and PyMVPA via hombrew and pip

this is my recipe in case you would like to try it out, it works on my Mac with el Capitan

#  Install command line tools

xcode-select --install

# Installing Brew
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
# Set up some taps and update brew
brew tap homebrew/science
brew tap homebrew/python
brew update && brew upgrade
# Install a brewed python
brew install python

#Install numpy, cython and h5py and scipy
pip install numpy
pip install scipy
pip install cython
brew install hdf5
pip install h5py
pip install nipy

#Install matplotlib with cairo support for png, ps, pdf and svg files
brew install matplotlib --with-cairo
#Relink numpy to brew as it was installed with pip
brew link --overwrite numpy
#Install Pandas
pip install pandas
#Install ipython with parallel and notebook support
brew install zmq
pip install ipython[all]
#install IDE ninja
pip install macfsevents
brew install ninja-ide
pip install -U scikit-learn
pip install nibabel
brew install swig

#Download PYMVPA from github and extract
git clone git://github.com/PyMVPA/PyMVPA.git<http://github.com/PyMVPA/PyMVPA.git>
unzip master
cd PyMVPA-master

#Build libsvm
sudo make 3rd

#Build PyMVPA itself
sudo python setup.py build_ext

#And install
sudo python setup.py install

If you get a locale error
ValueError: unknown locale: UTF-8
Either run these commands before running python or add them to your bash_profile or .profile
export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

On 22 June 2016 at 22:18, Yun-Ta Tsai <andytsai at mit.edu<mailto:andytsai at mit.edu>> wrote:
When i run the installation command:
$ sudo port install py27-pymvpa +scipy +nibabel +hcluster + libsvm + matplotlib + pywavelet

I get the following error:
--->  Computing dependencies for py27-pymvpa
--->  Building py27-pymvpa
Error: org.macports.build for port py27-pymvpa returned: command execution failed
Please see the log file for port py27-pymvpa for details:
To report a bug, follow the instructions in the guide:
Error: Processing of port py27-pymvpa failed

I've attached the log file. Would appreciate any help.

Andy Tsai
Computational Biologist at UCSF School of Medicine

Pkg-ExpPsy-PyMVPA mailing list
Pkg-ExpPsy-PyMVPA at lists.alioth.debian.org<mailto:Pkg-ExpPsy-PyMVPA at lists.alioth.debian.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pkg-exppsy-pymvpa/attachments/20160622/a6fd441b/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen Shot 2016-06-22 at 1.37.23 PM.png
Type: image/png
Size: 58513 bytes
Desc: Screen Shot 2016-06-22 at 1.37.23 PM.png
URL: <http://lists.alioth.debian.org/pipermail/pkg-exppsy-pymvpa/attachments/20160622/a6fd441b/attachment-0001.png>

More information about the Pkg-ExpPsy-PyMVPA mailing list