[postgis] 01/01: * Allow translations of the debconf notice for postgis-2.0 deprecation. * Add a German translation. * Downgrade package priority to extra.
markus at bluegap.ch
Tue Apr 8 19:14:11 UTC 2014
On 04/08/2014 08:04 PM, Sebastiaan Couwenberg wrote:
> Why did you chose to downgrade the priority?
Because of the following extra dependencies, for which the postgis
package currently seems to violate Policy 2.5:
(That's according to debcheck here:
> Both TinyOWS and pgRouting depend on postgresql-9.3-postgis-2.1
Somewhat off-topic: Can't TinyOWS run on a different server than the
database? Oh, it's just a recommends, fair enough.
However, that still reminds me: Both of these likely only depend on
'CREATE EXTENSION postgis;' to work (and result in some minimally
required PostGIS version). Other packages like
postgresql-9.3-postgis-2.0 or postgresql-9.2-postgis-2.1 should be able
to satisfy that dependency as well. (Granted, that's more of a pgapt issue.)
I'm not sure how to best express that dependency. Would a virtual
postgresql-X.Y-postgis-extension package make sense? So you could have a
dependency like postgresql-X.Y-postgis-extension >= 1.5, for example?
What do you think?
> Priority optional is usually the right choice, and recommended for all
> Debian GIS packages.
Back to the topic: Reading Policy 2.5, optional software is "all the
software that you might reasonably want to install if you didn't know
what it was and don't have specialized requirements"
I felt like that didn't apply to postgis (nor do I think that applies to
any GIS software). Thus, given the debcheck report and that wording, I
adjusted the priority.
Is there a general consensus that GIS stuff should rather have priority
optional? How should I deal with the above extra dependencies, in that case?
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 1574 bytes
Desc: OpenPGP digital signature
More information about the Pkg-grass-devel