Bug#613534: Seems to be rather a bug in nvidia, not the kernel

Andrei Popescu andreimpopescu at gmail.com
Wed Jun 1 18:12:34 UTC 2011

Sorry for the late reply, I keep getting distracted and forget about 
this :)

On Vi, 13 mai 11, 01:58:31, Andreas Beckmann wrote:
> On 2011-05-12 21:54, Andrei Popescu wrote:
> > I tested 270.41.06-1 with all the kernels I have installed:
> > 
> > $ dpkg -l linux-image-2.6.* | grep ^ii
> > ii  linux-image-2.6.32-5-amd64                    2.6.32-31                         Linux 2.6.32 for 64-bit PCs
> > ii  linux-image-2.6.36-trunk-amd64                2.6.36-1~experimental.1           Linux 2.6.36 for 64-bit PCs
> > ii  linux-image-2.6.37-2-amd64                    2.6.37-2                          Linux 2.6.37 for 64-bit PCs
> > ii  linux-image-2.6.38-1-amd64                    2.6.38-1                          Linux 2.6.38 for 64-bit PCs
> > ii  linux-image-2.6.38-2-amd64                    2.6.38-5                          Linux 2.6.38 for 64-bit PCs
> > 
> > With 2.6.36 it works, with 2.6.37 it doesn't. Anything else I can test?
> Does this mean up to 2.6.36 all is fine, 2.6.37 and later fails?

Yes. The key starts working just fine as soon as I switch to nouveau.

> What Xorg version are you using? There are three currently available:
> 1.7 (stable), 1.9 (testing), 1.10 (unstable). Does switching to a
> different Xorg version change anything?

I'm tracking sid very closely (update at least daily), unless I'm busy 
with real-life, so I think by now I switched a few versions. Currently 
I'm on 1.10.1.

I would like to test stable with 2.6.38 from backports, but the kbuild 
package is not available (yet?). Someone on -backports mentioned the 
package from testing works, so I'll try that later.

> How does your /etc/X11/xorg.conf look like? Have you tried a minimal one
> as described in /usr/share/doc/nvidia-glx/README.Debian.gz ?

My "xorg.conf" is minimal, see attached all files in xorg.conf.d/

> 2.6.39-rcX would be interesting, too.

$ uname -a 
Linux think 2.6.39-1-amd64 #1 SMP Tue May 24 14:34:19 UTC 2011 x86_64 GNU/Linux
$ dpkg -l nvidia-glx | grep ^ii
ii  nvidia-glx                                    270.41.19-1                       NVIDIA binary Xorg driver

Still not working :(

> Have you searched the nvidia forum whether someone has reported
> something similar?

Not yet, but will do.

> If none of these possibilities brings a solution, you should report this
> directly to nvidia, following their instructions here:
> http://www.nvnews.net/vbulletin/showthread.php?t=46678

I'll test the beta in experimental first, as you suggested in the other 

Regards and thanks for reading,
Offtopic discussions among Debian users and developers:
-------------- next part --------------
Section "Device"
	Identifier	"Configured Video Device"
	Driver		"nvidia"
-------------- next part --------------
Section "Serverflags"
	Option		"BlankTime"	"0"
	Option		"SuspendTime"	"20"
	Option		"OffTime"	"30"
-------------- next part --------------
Section "InputClass"
	Identifier	"TrackPoint"
	MatchProduct	"TrackPoint|Stick"
	Option		"AccelerationProfile"	"6"
	Option		"EmulateWheel"
	Option		"EmulateWheelButton"	"2"

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-nvidia-devel/attachments/20110601/e52bc510/attachment.pgp>

More information about the pkg-nvidia-devel mailing list