[sane-devel] epson 1200 usb hangs

Bob rramsey@soli.inav.net
Wed, 29 Aug 2001 20:23:35 -0400

Ok, I think part of my problem may have been my own stupidity, but only 
partly and it still doesn't explain everything.

I was getting my instructions from 

and they have a list of vendor and product id's.  0x04b8 and 0x0104 
respectively for the perfection.  When I was running modprobe, I was using 
the 0x prefix for the numbers, as they appeared in the table of instructions. 
 And that worked fine earlier.  Today when I tried it, I eliminated the 0x 
prefix and it worked a lot better.  I had assumed that the 0x prefix was 
required to indicate that the numbers being passed were hex based.  Plus, it 
worked pretty well.  Until it didn't. ;)

Tonight it was hanging on me, but when I ran modprobe and removed the 0x 
part, it worked.  I've been scanning at 600 dpi with no problems.  I haven't 
tried 750 dpi yet, mainly because 35-40 megs per file is large enough for me 
at this time.  When I get the dvd burner, then I'll really make some big 
pictures. ;)

And I've found out that when it does hang, I shouldn't use xkill to kill 
xsane.  I should shut off the scanner first, wait a few minutes for xsane to 
generate an error.  If I kill xsane,  I can't get the scanner back, but if I 
shut it off first, I can re-run modprobe and get the scanner back.

Thanks to all those people who offered suggestions.  I really appreciated the 

And thanks to the developers for some good software.