[sane-devel] Acer 640BU :-(

Desmond Rivet des_riv@sympatico.ca
Sun, 09 Sep 2001 16:53:33 -0400

Hi all,

This is apparently a developers mailing list. Ummm...I'm I'm in the
wrong place, could you kindly point wher I should look?

I have an Acer 640BU scanner that doesn't appear to be working. I run
RedHat7.1 linux. My USB system is apparently working, and my scanner is
recognized at that level, since I get the following when I do a "more"
on /proc/bus/usb/devices:

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=b400
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs=  1
P:  Vendor=04a5 ProdID=207e Rev= 1.00
S:  Manufacturer=Color
S:  Product= FlatbedScanner 13
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=   8 Ivl=  0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl= 16ms

As you can see, I have a device listed as "Vendor=04a5 ProdID=207e Rev=
1.00". I checked and this is indeed the code for my scanner. The
"Product= FlatbedScanner 13" part is also a clue :-)

So far so good. I also checked my /dev directory and found all sorts of
scanner files (though I don't know exactly what these are used for).
Specifically, I found :


I did *NOT* find any /dev/usbscanner or /dev/scanner files. Are these
necessary? How do I make them?

Now I checked my /etc/sane.d directory and found a whole bunch of */conf
files. I assume the one I have to modify is snapscan.conf, correct? So I
modify that file to have only one line:

usb /dev/usb/scanner0

Now I'm thinking I've done everything I need to. However, when I run
xsane, it complains that no devices are available. Running scanimage
--list-devices also produces no output at all.

Soooo...does anyone have any ideas as to what's going on, now that I
have rambled a bit. Any help is truly appreciated!

Thanks in advance...

Desmond Rivet                                    des_riv@sympatico.ca
Programmer Wannabe

  Is life worth living?  That is a question for an embryo, not a man.
		  --Samuel Butler