[sane-devel] Unable to access minor data

Henning Meier-Geinitz henning@meier-geinitz.de
Tue, 3 Dec 2002 20:14:51 +0100


On Tue, Dec 03, 2002 at 06:48:20PM +0000, Alexis wrote:
> I did a fresh install of Debian 3.0 (Woody) (gcc2.95.4) I applied patches to 
> kernel and to sane from http://viceo.orcon.net.nz/ as recommended, have been 
> trying to run sane-find-scanner and scanimage-L.
> sane-find-scanner seems unable to find any usb scanner devices, while 

Then it doesn't make sense to go on. First make sure that the scanner
is detected by sane-find-scanner. Load the scanner module with the
vendor and product id of your scanner (see man sane-usb). Also have a
look at /proc/bus/usb/devices, the scanner should be listed with

> scanimage -L gets as far as
> [viceo] attach: opening usb /dev/usb/scanner0 
> [viceo] ----ScLoader----
> and then gives the same message as sane-find-scanner, which is
> scanner.c: open_scanner(0): Unable to access minor data

That's a warning message only. This means, that the backend tried to
open /dev/usb/scanner0 but the scanner module hasn't detected any
scanner so the open fails.

> It looks as though sane can't connect to the scanner device.  I don't think 
> it's a faulty connection as it is a new machine and I have tried both usb 
> ports, and there are lots of scanner devices under /dev/usb.

It's not a problem of SANE but of the kernel scanner driver.