[sane-devel] Vuego 310S scanner help

c1sc0@mac.com c1sc0@mac.com
Thu, 26 Dec 2002 09:04:52 +0100

May be related to the troubles I'm having with my Vuego 610s on 
Mandrake 9.0. Uses same snapscan back-end. I've got it working using 
console command scanimage but xsane doesn't recognize the device. This 
is what I've done:

1) explicitly added aic7xxx support in my /etc/modules.conf file
2) uncommented all usb-related stuff in /etc/sane.d/snapscan.conf
3) only device listed in /etc/sane.d/snapscan.conf now is /dev/sg0
4) The device name for my Scanner is Flatbedscanner_4 so I've added 
"Flat *" to snapscan.conf. I'm not sure if this helps though. Anyone 
care to educate me about this?

Now I have two devices listed in /proc/scsi/scsi (CD-R + 
Flatbedscanner), sane-find-scanner lists my scanner but scanimge -L 
doesn't list it. Weird.

I'm calling scanimage and redirecting stdout to file like this:

scanimage --format=tiff -d snapscan:/dev/sg0 > 

xSane still doesn't work though. There's no option to select Vuego 610s 
in Harddrake, but I understand it's a rebranded Acer 610 so I've 
installed that. Still not working. I'd like to get it to work but if 
there's no workaround I guess I can live without it.  ;-(

I'm going to try the earlier dll.conf comment tonight. I noticed that 
after running Harddrake there was an empty file called SnapScan.conf in 
addition to snapscan.conf. At the time I didn't know what it was so I 
modded it to have /dev/sg0 as device just like snapscan.conf. Seems 
like built-in Mandrake scanner support uses wrong spelling.

Cheers & merry x-mas !

On woensdag, dec 25, 2002, at 00:47 Europe/Brussels, David Blomberg 

> A friend has asked me to help locate a problem he has on his new
> Mandrake 9.0 system in which the system shows the scanner but XSANE 
> does
> not see it.  in his own words:
> "My scanner is a vuego 310s. I installed it under win95. it works well
> under win98se
> I installed an interface card in an isa-bus slot and hooked the scanner
> to the pc using an old fashioned scsi cable ... wide as distinct from
> the modern ones which do not have
> The Vuego is listed by Mandrake anderhardware > scanners
> as su I set up the scenner using this program and was told scanner
> installed use xsane to run it
> when I hit the xsane button I got the response xsane: no devices
> available
> so I went to SANE on the web and looked at sane-snapscan.5 (it lists
> Vuego 310s) which I have printed out and am trying to understand
>        This backend expects device namse of the form:
>               special"
> I had him run sane-find-scanner which you can find the listing for in
> "vuego.txt" and then being we are not sure which dev the scanner is
> under I had him give me a listing of the /dev and sub-dirs (happy.txt)
> If anyone has any help to offer please let me know as he really would
> like to get this fixed.
> Thank You
> David Blomberg
> cybersekkin@yahoo.com
> dblomber@libertec.com
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel