[sane-devel] Unable to access minor data

Henning Meier-Geinitz henning@meier-geinitz.de
Thu, 4 Jul 2002 15:25:57 +0200


On Thu, Jul 04, 2002 at 06:39:20AM -0400, El Zorro wrote:
> I have an USB Acer ScanPrisa 640U, I have installed latest SANE version, 
> when I run the command: sane-find-scanner I got the following answer:
> sane-find-scanner: found USB scanner (vendor = 0x04a5, product = 0x2060) 
> at device /dev/usb/scanner0
> However when I tried "scanimage -d acer:/dev/usb/scanner0"

The first part of the SANE device name is the backend. As there is no
backend named "acer" this device name doesn't make much sense :-)

> or 
> "scanimage -d snapscan:/dev/usb/scanner0"  I got the following:
> scanimage: open of device snapscan:/dev/usb/scanner0 failed: Invalid 
> argument

Does "scanimage -L" list anything? Maybe you need to edit
snapscan.conf and enter the file name of the firmware file? See man
sane-snapscan for details.

> What may I try to work with this scanner?

When you run "SANE_DEBUG_SNAPSCAN=255 scanimage -L" you or the
snapscan developers may get a clue what's wrong.