[sane-devel] re:re: Problem with Acer 640UT, worked before

Matts kivik@firstlinux.net
Thu, 18 Jul 2002 03:17:57 -0700 (PDT)


Thanks for your help. I have followed ypur instructions, and this is what scanimage -L dumps: (There is one thing: I have not got a Acer620 scanner...but an 640UT, I dont know the vendor and product numbers for it, but it has worked in previsous versions of sane)

[root@localhost root]# export SANE_DEBUG_SNAPSCAN=255
[root@localhost root]# scanimage -L
[sanei_debug] Setting debug level of snapscan to 255.
[snapscan] sane_snapscan_init
[snapscan] sane_snapscan_init: Snapscan backend version 1.4.13
[snapscan] add_usb_device(/dev/usb/scanner0 bus=usb)
[snapscan] add_usb_device: Detected (kind of) an USB device
[snapscan] snapscani_usb_open(/dev/usb/scanner0)
[snapscan] add_usb_device: Checking if 0x04a5 is a supported USB vendor ID
[snapscan] snapscani_check_device()
[snapscan] mini_inquiry
[snapscan] snapscan_cmd
[snapscan] snapscani_usb_cmd(4,0xbfffe260,6,0xbfffe230,0xbfffe22c (36))
[snapscan] atomic_usb_cmd(4,0xbfffe260,6,0xbfffe230,0xbfffe22c (36))
[snapscan] usb_cmd(4,0xbfffe260,6,0xbfffe230,0xbfffe22c (36))
[snapscan] usb_cmd: cmdlen=6, datalen=0
[snapscan] usb_write: writing:  0x12 0x00 0x00 0x00 0x24 0x00
[snapscan] usb_read: reading:  0xf9 0x00 0x00 0x00 0x00 0x00 0x00 0x00
[snapscan] usb_read: reading:  0x06 0x00 0x02 0x02 0x49 0x00 0x00 0x00 0x43 0x6f ...
[snapscan] usb_read: reading:  0xfb 0x00 0x00 0x00 0x00 0x00 0x00 0x00
[snapscan] snapscani_check_device: Is vendor "Color" model "FlatbedScanner13" a supported scanner?
[snapscan] snapscani_get_model_id(FlatbedScanner13, 4, 2)
[snapscan] snapscani_get_model_id: looking up scanner for ID 0x04a5,0x2040.
[snapscan] snapscani_check_device: Autodected driver: Acer620
[snapscan] snapscani_usb_close(4)
[snapscan] snapscani_init_device_structure()
[snapscan] add_usb_device(/dev/usb/scanner0)
[snapscan] sane_snapscan_get_devices (0xbffff404, 0)
Segmenteringsfel (core dumped)

>On Wed, Jul 17, 2002 at 02:16:19PM -0700, Matts wrote:
>> I have had this scanner working fine in a previous Mandrake and sane
>> version. What happens after a compleete system upgrade is that xsane
>> searches for units forever at start. I have upgraded Mandrake 8.2's
>> sane 1.0.7 to 1.0.8, but the same problem exactly was there before
>> the upgrade too. 
>I'm not a SnapScan expert...
>> My devices list looks like this:
>> I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbscanner
>Detected by the USB scanner driver, fine.
>> And I have a symlink:
>> [root@localhost root]# ls /dev/scanner -l
>> lr-xr-xr-x    1 root     root           17 jul 18  2002 /dev/scanner -> /dev/usb
>> /scanner0
>Ouch! Never do that. You have just advised all the SCSI drivers to
>send SCSI commands to your USB scanner. Your scanner probably doesn't
>like SCSI commands :-)
>With SANE 1.0.8 this shouldn't matter, but you should remove the link
>nevertheless. With fairly recent Linux kernels USB scanners are
>detected automatically by most SANE backends.
>Does sane-find-scanner find your scanner?
>> and /dev/usb/scanner0 does exist, when the scanner is plugged in.
>So you use devfs (device file system)? Are the premissions set up
>correctly? For testing, try as root.
>Try removing/commenting out everything from dll.conf but "snapscan".
>Run scanimage -L and scanimage -T. If it still hangs, try to set the
>debug variables, e.g.:
>and run scanimage again. Maybe you can see what's going on.
>  Henning
>Want a new web-based email account ? ---> http://www.firstlinux.net
>Promote your group and strengthen ties to your members with email@yourgroup.org by Everyone.net  http://www.everyone.net/?btn=tag

Want a new web-based email account ? ---> http://www.firstlinux.net

Promote your group and strengthen ties to your members with email@yourgroup.org by Everyone.net  http://www.everyone.net/?btn=tag