[sane-devel] sane doesn't find my Epson Perfection 1650

Karl Heinz Kremer khk@khk.net
Sun, 21 Jul 2002 15:01:19 -0400

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Good, you are very close to a working scanner. Unfortunately I don't know
which step is missing. You should aready have a working system. Can you ple=
run the following commands in a terminal window:

xsane > /tmp/scan.log 2>&1

Then try to start xsane again and email the log file /tmp/scan.log to me=20
(please don't send it to the list, it would only waste bandwidth)

Karl Heinz

On Sun, Jul 21, 2002 at 02:23:25PM -0400, Jason M. Burns wrote:
> I can find my scanner (an Epson 1650) in /proc/bus/usb/devices
> and in sane-find-scanner's output, but when I run scanimage it tells me
> 'scanimage: no SANE devices found'.  xsane gives a similar error.
> I'm running Red Hat 7.2.
> Things I've tried:
> 1) 'modprobe scanner'; I need to do this to have the system see the scann=
> 2) Specifying the options 'vendor=3D0x04b8 product=3D0x0110' when modprob=
>    or in modules.conf.
> 3) Upgrading sane to 1.0.7, from the RedHat 7.3 packages
> (sane-frontends, sane-backends, sane-backends-devel, and xsane-0.84).
> 4) Upgrading my kernel from 2.4.7-10 to 2.4.9-34.
> 5) Adding the line 'usb /dev/usb/scanner0' to epson.conf, and
>    commenting out all other lines; this is the device reported by
>    sane-find-scanner.
> 6) Changing permissions on /dev/usb/scanner0 from 600 (read/write for
>    user jason only) to 666; this shouldn't make any difference, because
>    I've tried all these as user jason, but I'm out of ideas.
> 7) Replacing dll.conf with the single line 'epson', to avoid using
>    other backend drivers.
> --
> Jason Burns
> burns@math.mit.edu
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

Karl Heinz Kremer                                  khk@khk.net
PGP Key at                 http://www.khk.net/download/khk.asc
EPSON Sane Backend:                         http://www.khk.net

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org