[sane-devel] Problem with network scanning Linux/win98

Edvard Rognlid edvard@rognlid.com
Sun, 05 May 2002 12:50:38 +0200

Hay, I have a problem accessing my scanner using my LAN. I'm a newbee to 
Linux so I'm not suprised if I have forgot something or made an error in 
one of the config files.

I us a Microtek E3 SCSI scanner on a adaptec card. My server also have an 
onbord scsi card that I use for my discs, CD-rom and tapestreamer.

I can access my scanner using when sitting on then Linux-box. But not using 
LAN for my windows computer.
I use RedHat 7.2 linux
I have how ever one problem using the linux box. If I restart it I have to 
type "modprobe aha152x aha152x=0x340,9" before it works. What shoud I do to 
start this automaticly?

Over to my main problem, accessing the scanner from win98
I have tried reading different help files and belive I'v edited the files 
that I should.

from saned.conf
# saned.conf
# The contents of the saned.conf file is a list of host
# names that are permitted by saned to use local SANE
# devices in a networked configuration.  The hostname
# matching is NO LONGER case-sensitive.

** barcelona is my server
** radich is my win98 computer

from /etc/services
# Added by Edvard 30/04/02
sane            6566/tcp                        # SANE network scanner daemon

from xinetd.conf
service sane
    port        = 6566
    socket_type = stream
    wait        = no
    user        = saned
    group       = saned
    server      = /usr/sbin/saned
    protocol    = tcp

includedir /etc/xinetd.d

In one helpfile I read that trying to us "telnet localhost 6566" could tell 
me if things worked. Trying this both form my win98 and linux computer I 
get the same resolt:
[root@barcelona etc]# telnet barcelona 6566
Connected to barcelona.
Escape character is '^]'.

And then it just hangs - nothing happens.

Trying scanimage -L from my linux box give this result:
[root@barcelona etc]# scanimage -L
device `microtek:/dev/sge' is a Microtek ScanMaker E3 flatbed scanner
device `microtek:/dev/sg4' is a Microtek ScanMaker E3 flatbed scanner

Anyone that can help?

Regards Edvard Rognlid
Hammerfest, Norway