[sane-devel] Problems problems problems

Gene Heskett gene.heskett@verizon.net
Wed, 2 Apr 2003 08:09:19 -0500

On Wed April 2 2003 04:36, Steven Lobbezoo wrote:
>It's amazing that no one ever writes about something that was a
> succes to a mailing list, but i'm affraid i have to confirm to
> this standard ;-))
>I'm working with Linux Suse 8.1 and sane 1.0.8-47  on a PC.
>My scanner is a Epson Perfection 1260 (USB).
>I installed one in a seperate office, no problem. Took me 5
> minutes and with Gimp and XSane it was working like a charm!
>Then i started installing in this office (same software, same
> scanner), and I cannot get it to work.

But, its probably not the same motherboard/chipset combo on that 
motherboard.  This duck walks and quacks exactly like one of mine, 
an older TYAN S-1590 motherboard, with an early via chipset driving 
its usb headers.

This 82C586 (IIRC) chipset can *usually* handle a usb mouse, only 
losing it after 2 or 3 months uptime.  Most of the time its fine.

But move my 1250 to one of its plugins, and build sane on it and 
VIA's inability to really build a usb right the first time will be 
demonstrated.  All the tests will work just fine, so you fire up 
xsane and actually try to do a scan and you rapidly find, usually 
within the first megabyte downloaded from the scanner, that the 
machine is hung so tightly that even the toolbar clock is stopped, 
and that the machines only response to anything is the hardware 
reset button.

As ext2 doesn't like that, and neither does reiserfs, usually 
requireing that the drive be fscked and the os re-installed, after 
doing that 4 or 5 times I gave up.  The scanner sat there looking 
smug and saying 'Gotcha'.

About that time I decided to build a faster machine using a 
different motherboard, this time a Biostar M7VIB.  When it was up 
and running I moved the scanner cable to one of its usb ports, 
installed the exact same version of sane by copying the src's over 
a samba link and recompiled it.  Over about half the life of 
sane-*-1.x now, its worked exactly as Gerhard wrote the code to 
make it do, and at the moment I'd use it for production if I had 
any.  And its never locked the machine up.

The Moral is that some machines usb hardware is so broken there is 
no hope of running a scanner on one of them.  That early 1998 TYAN 
mobo is one in that category.

>I tried to exchange scanners and cables, both of them are working
> fine in the other office.
>I tried to install the latest release of sane, but it needs
> GLIBC2_3, and i cannot install that (inpossible to find a
> compiled version, try to compile myself, but the library does not
> work - after 2 days i gave up on that). So i went back to the
> mentioned version. The scanner is recognized by the system. As
> soon as i put the cable in it appears on my desktop, it seems to
> be ok, when i make a hardware scan it's found, KDE say's it's
> just fine.
>But if i try to start Xsane (or do the test during Yast
> installation) it just hangs! Nothing happens. I tried to start
> "xsane /dev/usb/scanner0", but then it comes back with an error 5
> and dumps core.
>For your info: I've tried to connect other USB equipment (a
> camera) to the USB port and that works just fine.
>It must be something in the software, but i cannot figure it out.
>Please can anyone give me a tip what to do ?
>Thanks in advance.
>Sane-devel mailing list

Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz  512M
99.25% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com attornies please note, additions to this message
by Gene Heskett are:
Copyright 2003 by Maurice Eugene Heskett, all rights reserved.