[sane-devel] saned/Epson problems - ?third try?

Henning Meier-Geinitz henning@meier-geinitz.de
Tue, 7 Jan 2003 11:52:17 +0100


Hi,

On Tue, Jan 07, 2003 at 09:53:31AM +0100, Lars Tšuber wrote:
> we use a scan-server with an epson scanner attached.
> this server has no x, so we can't test xsane or xscanimage localy.
> first i wrote to khk, because we thought it was a xsane problem.
> 
> now we encounter a cancel problem with xscanimage and net backend too.

scanimage works?

> i attached the scanner to a linux box running X and had no problems 
> using xsane with the local epson backend.

You are using the standard epson backend that comes with sane and not
the epson kowa backend made by Epson?

Which version of SANE do you use on the server?

> we can't switch to color mode or to transparency unit using xsane over 
> net backend

What error happens? Please show us the complete output in syslog that
was generated by saned. Example:

Jan  7 11:43:06 hmg1 saned[9424]: connect from hmg1
Jan  7 11:43:06 hmg1 saned[9424]: saned from sane-backends 1.0.9-cvs ready 
Jan  7 11:43:06 hmg1 saned[9424]: check_host: access by remote host: 127.0.0.1 
Jan  7 11:43:06 hmg1 saned[9424]: init: access by hmg@127.0.0.1 accepted 
Jan  7 11:43:23 hmg1 saned[9424]: quit: exiting 

Does the error also happens if you use the test backend? e.g. 
xsane net:hostname:test

> xscanimage works so far - only canceling scanning freezes xscanimage
> (over net backend)

The implementation of the cancel function in SANE can be tricky and
the net backend sometimes shows bugs that aren't apperent without it.
But it's hard to tell the cause when the problem can't be reproduced.
So I guess it's up to the backend maintainer to find out what's wrong
here, if he can reproduce :-)

I tried with my (non-Epson) scanners and can cancel scans without
problems.

Bye,
  Henning