[sane-devel] Mustek BearPaw 2400 CU plus: now I'm totally confused (was: suddenly problems opening /dev/usbscanner0)

Henning Meier-Geinitz henning@meier-geinitz.de
Mon, 2 Jun 2003 15:58:33 +0200


On Mon, Jun 02, 2003 at 11:15:26AM +0200, Christoph Bier wrote:
> As written in my last posting in the thread "suddenly 
> problems [. . .]" I installed my scanner at the pc at 
> work. Didn't help. BUT: after plugging in again the 
> other, former at this pc installed (working!) scanner, 
> I get the same error message starting xsane for this 
> scanner, that worked 2 minutes before!

Maybe plugging in your (home) scanner confused the kernel. Do you get
any messages from the USB system in /var/log/messages when you plug-in
the scanner?

>    I'm totally confused now. Only unplugging (and 
> plugging in again) makes the scanner stop working. 
> Even after rebooting the system, there's an error 
> opening /dev/usbscanner0.

Or your distribution found the scanner and used some hotplugging magic
but failed. And that stops your scanner from beeing detected again.
But that's not easy to diagnose from remote.

>    USB-devices are hot-pluggable, aren't they?! 


> Could I have destroyed the scanners by unplugging them while the
> pc was running??

No. I don'tt day it's not edefective but if it is, it's not because
you unplugged it. I'm doing that all the day with my USb scanners and
that's the whole idea of USB.