[sane-devel] Avision backend trouble (?) (was: multiple images on XSane)

Henning Meier-Geinitz henning@meier-geinitz.de
Fri, 13 Jun 2003 12:14:24 +0200


On Mon, Jun 09, 2003 at 06:42:08AM +0100, F J Brooks wrote:
> On Sat, 31 May 2003 09:15:11 +0200, Henning Meier-Geinitz
> <henning@meier-geinitz.de>
> wrote:
> > So an older version of xsane works? The current version is 0.91, by
> > the way.
> Is there any advantage to me in installing xsane 0.91, eg, will it solve my
> current problems? I installed v.0.90 only two or three weeks ago (when it
> was then the latest).

I don't think so but I haven't seen your problem with any of my
scanners so I can't be sure. I was more interested in the first part
of the question, however :-)

My questions try to find out if it's a frontend (xsane) or backend
problem. As you say quiteinsane works, that would point to a frontend
problem. However, the description of the bug looks more like a backend
problem. Further more, there are no other reports of such a bug as far
as I know so I don't really know what's going on.

> > Which version of sane-backends do you use?
> The version of sane-backends (and sane-frontends) I have is  1.0.11.

1.0.12 is current but I don't know if that fixes your problem.

> > Does it depend on resolution or mode setting? Only in viewer mode or
> > also in the preview window and when you save the image?
> It doesn't depend on mode, in that I get the same result in the viewer
> window,

With "mode" I meant color, gray or lineart.

> when I copy/print, and if I save the image to file and then print.

Is the image already corrupted when displayed on the screen or is only
the print wrong?

> The preview window doesn't seem to work in that it shows a dark, hatched
> strip about 3 cm wide across the top of the window, with the rest of the
> window area (A4) white.

That's a bad sign. Maybe really a backend problem because it doesn't
happen with any of my backends and XSane.

But the scanner does scan (move the scan slider) when you press the
"Acquire preview" button?

> > Different speed are rather uncommon when using different frontends. Are
> > you sure that you have only one version of sane-backends installed?
> No, I found that I also had sane-backends-1.0.8 [the original which came
> with my SuSE distribution]. So I removed it (using YaST2). That's when
> things got even worse!
> I found that, when I clicked on my desktop scanner icon to open
> /usr/local/bin/xsane, I got the error message:
> 'Sorry - KDesktop: KDEInit could not launch '/usr/local/bin/xsane'.

Probably that xsane version was linked against your 1.0.8 SANE
backends. That would explain why quiteinsane worked.

Just rebuild xsane from source again. Now that you have only one
version of sane-backends, it should find that one and link against it.
In fact I'm a bit surprised that it doesn't work out-of-the-box.

> When I tried the same thing using Konqueror, I got the error message:
> 'Error - Konqueror: Unable to run the command specified. The file or
> directory file: /usr/local/bin/xsane does not exist.'

Well, this message is pretty much clear :-)

> I found this rather surprising so I tried:
> fredjb@FJBrooks:~> ls -l /usr/local/bin
> drwxr-xr-x    7 root     root          816 2003-06-05 17:00 sane-frontends-1.0.11

that's odd. You shouldn't place the source directory of sane-frontends
in the directory for binaries. Better use /usr/src or your home

> drwxr-xr-x    9 root     root         1344 2003-06-05 16:56 xsane-0.90

Same here.

> [Many of these were recently downloaded from their source sites on the net,
> to
> replace older, out-of-date versions.]

Yeah, but you did build them from source, did you? And not just
unpacked them in /usr/local/bin?

xsane (the binary) is just nor there. I don't think that yast removed

> fredjb@FJBrooks:~> sane-find-scanner
> found SCSI scanner "HP ScanJet 5300C 6.00" at /dev/scanner
> found SCSI scanner "HP ScanJet 5300C 6.00" at /dev/sg2

> Followed by:
> fredjb@FJBrooks:~> scanimage -L
> device `avision:/dev/scanner' is a Hewlett-Packard ScanJet 5300C flatbed
> scanner
> device `avision:/dev/sg2' is a Hewlett-Packard ScanJet 5300C flatbed
> scanner
> fredjb@FJBrooks:~>

Also ok.

> I then tried [I have extracted only the bits I thought relevant to my
> scanner]:
> SANE_DEBUG_DLL=255 scanimage -L
> [sanei_debug] Setting debug level of dll to 255.
> [dll] sane_init: SANE dll backend version 1.0.8 from sane-backends
> 1.0.11

Ok, that's the new backend.

> > What happens if you scan with scanimage? E.g. "scanimage >image.pnm".
> > Or xscanimage?
> Tried: fredjb@FJBrooks:~> scanimage >image.pnm
> Scanner whirred quietly for a while, but no other response.

Well, is the image ok (image.pnm)? Display it with e.g. gimp, quiv or

> Then tried: xscanimage:
> Got 'Select Device' panel giving choice:
> 'avision:/dev/scanner
> avision:/dev/sg2
> Chose former, clicked 'OK', got: avision/dev/scanner window, on which
> clicked: 'Preview Window'. Got Preview Window, dragged dashed line into
> rectangle covering roughly A4 size,

Are you sure you started at the top left edge? SOme backends don't
like it if you get the coordinates the wrong way. 

> then clicked 'Acquire Preview'.
> Scanner made fairly loud scratching-type noise plus hum, then
> intermittent whirring noise.
> Nothing appeared in Preview Window, and 'Acquire Preview' button
> reappeared.

Anyway, preview
should always show the whole scanning area. So it looks like a backend

> Clicked 'Scan' on main window.  After a minute or two, scanner started with
> whirring noise, and got 'Scanning' panel with 'Receiving RGB data for
> out.pnm' progress bar graphic. Also second panel headed: 'Output Filename',
> listing directories and files.
> After ten-plus minutes,

That's really slow. But it may be faster if you set a lower resolution.

> scanning seems complete and 'Scanning' panel
> disappears. Open out.pnm file and get colour image of object, slightly
> distorted as is longer and thinner than original.

Backend problem. But at least it scans at all.

> So that's where I am, Henning - as you can see, in rather a mess.
> Anything you can do to resolve the situation would be much
> appreciated. 

My final thought is that there is a problem with the avision backend
you use. The frontend shouldn't matter. I you install xsane again,
it'll probably show the same symptoms. scanimage should also be the

Try lower resolutions. Try sane-backends 1.0.12. If that doesn't help,
ask the avision maintainer for help if you didn't do already (Rene
Rebe <rene.rebe@gmx.net>).