[sane-devel] FreeBSD and Microtek Scanmaker II

abel deuring a.deuring@satzbau-gmbh.de
Sat, 21 Jun 2003 16:38:43 +0200

Henning Meier-Geinitz wrote:

> Ok. I haven't tested FreeBSD with older scanners for some time so here
> are my results with Mustek SCSI scanners (symbios-compatible 810 SCSI
> controller, FreeBSD 5.0, sym driver):
> Scanner                                        1.0.12         your patch
> ------------------------------------------------------------------------
> ScanExpress 6000 SP (relatively new)           ok             ok
> Paragon 1200 SP Pro (relatively new)           detected,      same
>                                                but timeout
> Paragon 12000 SP (older)                       not detected   not detected
> Paragon 12000 CX (stone age three-pass)        not detected   not detected
> If I try to use the "ncr" driver instead of "sym", FreeBSD doesn't
> even boot. With a Tekram 315 controller the results are the same as
> above.
> So your patch is ok but FreeBSD 5.0 is unusable with older Mustek
> scanners on at least these controllers. The scanners work just fine on
> Linux.

But we have least no new problems ;)

> The timeout with the Paragon 1200 SP Pro occurs when the lamp warms up
> that warm-up can take upto about 70 seconds. With Linux and the later
> SANE versiosn that's not a problem but FreeBSD seems to ignore the 120
> seconds timeout. When the lamp is warm, the scan starts ok but sounds
> horribly and never finishes. No idea why, but this also happens
> without your patch.
> The "not-detection" looks like this: Booting FreeBSD stops and the
> scanner LED starts blinking. Looks like the scanner gets sent an
> invalid command from the kernel. If I turn off the scanner, FreeBSD
> boots. When I run "camcontrol rescan all", the scanner blinks again
> and camcontrol freezes.
> If I remember correctly, the old scanners worked once with FreeBSD. So
> maybe 5.0 has broken the SCSI system?

It could be that it does not like older, very slow SCSI devices. IIRC,
some Linux SCSI adapter drivers could not detect the Scanmaker II during
a modprobe. The problem was that the scanner was too busy after a bus
reset that it did not respond to the typoical INQUIRY. A later "echo
scsi add-single-device ..." fixed that.