[sane-devel] FreeBSD and Microtek Scanmaker II

Henning Meier-Geinitz henning@meier-geinitz.de
Sat, 21 Jun 2003 14:52:53 +0200


On Fri, Jun 20, 2003 at 08:51:26PM +0200, abel deuring wrote:
> Henning Meier-Geinitz schrieb:
> >I'm not volunteering :-) but I can at least test if any of your
> >patches break Mustek scanners on FreeBSD. 
> Great. I've already sent a patch to Martin, and it seems to fix the 
> problems with the Microtek Scanamker II. Attached is the proposed new 
> version (with Martin's fixes of my typos) of sanei_scsi_cmd2 for 
> FreeBSD/CAM. It should replace the function near line 2765 in sanei_scsi.c.

Ok. I haven't tested FreeBSD with older scanners for some time so here
are my results with Mustek SCSI scanners (symbios-compatible 810 SCSI
controller, FreeBSD 5.0, sym driver):

Scanner                                        1.0.12         your patch
ScanExpress 6000 SP (relatively new)           ok             ok
Paragon 1200 SP Pro (relatively new)           detected,      same    
                                               but timeout
Paragon 12000 SP (older)                       not detected   not detected
Paragon 12000 CX (stone age three-pass)        not detected   not detected

If I try to use the "ncr" driver instead of "sym", FreeBSD doesn't
even boot. With a Tekram 315 controller the results are the same as

So your patch is ok but FreeBSD 5.0 is unusable with older Mustek
scanners on at least these controllers. The scanners work just fine on

The timeout with the Paragon 1200 SP Pro occurs when the lamp warms up
that warm-up can take upto about 70 seconds. With Linux and the later
SANE versiosn that's not a problem but FreeBSD seems to ignore the 120
seconds timeout. When the lamp is warm, the scan starts ok but sounds
horribly and never finishes. No idea why, but this also happens
without your patch.

The "not-detection" looks like this: Booting FreeBSD stops and the
scanner LED starts blinking. Looks like the scanner gets sent an
invalid command from the kernel. If I turn off the scanner, FreeBSD
boots. When I run "camcontrol rescan all", the scanner blinks again
and camcontrol freezes.

If I remember correctly, the old scanners worked once with FreeBSD. So
maybe 5.0 has broken the SCSI system?