[sane-devel] CanoScan LiDE 30 mystery solved

Christopher Marshall christopherlmarshall@yahoo.com
Thu, 8 Jan 2004 09:24:51 -0800 (PST)

--- Christopher Marshall <christopherlmarshall@yahoo.com> wrote:
> I had it working great through libusb on three different linux machines (all running slackware
> 9.0) for a week or so and now, all of a sudden, it either gives me black scans (vertical bands
> of
> black and white), or it makes a hideous noise (as if it is trying to move the motor in the wrong
> direction).
> I wondered if perhaps I did something to get the scanner in a wierd state, so I did a scan on a
> windows machine (using the software that came with the scanner) and it worked normally.  Then I
> put it back on the nearest linux machine and got the same hideous noise.
> I'm crushed :-(
> Any ideas?

I figured it out.  I was not copying my plustek.conf file to the proper place (in my case
/usr/local/etc/sane.d/plustek.conf).  However, since I was working in the same directory I had
written the correct plustek.conf file in, scanimage was working there.  When I would go to another
directory, it would stop working.

That's because the plustek backend looks in the current directory and if it finds a plustek.conf
file there, uses it instead of the one in /etc or /usr/local/etc.  That really threw me for a

The man page for sane-plustek doesn't mention that it looks in the current directory for

Chris Marshall

Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes