[sane-devel] FC 5 has problem when detecting sm 3600

Tamkang power_station_2001 at yahoo.com
Tue Apr 11 03:15:50 UTC 2006

Olaf Meeuwissen <olaf.meeuwissen at avasys.jp> wrote: Tamkang 

> I have a problem when want to debug the xsane to detect where the sm3600 was
> ?� it appears no device ? first of all the xsane in /usr/bin/xsane it work,
> then if in /usr/local/bin/xsane, it cannot find out the scanner ? and I have
> question to ask , because fc5 is have no /etc/hotplug anymore,� and is being
> replace /etc/udev/60-libsane.rules, I already see the sm3600 is already there,
> is it the xsane will always look the data in 60-libsane.rules to see the
> device is supported by xsane /sane ? but why in sane-find-scanner it cannot
> find out the scanner, neither the scanimage -L but the xsane in /usr/bin/xsane
> it can work normally ?
> I need explaination

Would you happen to be running your FC5 with an SELinux policy that
enforces everything?  Try the Permissive policy instead.

When test driving iscan-2.0.0 on FC5 this worked around problems with
sane-dll not being to able to load iscan's epkowa backend (where all
backends from the sane-backends package were loaded fine).

Hope this helps,
Olaf Meeuwissen                          EPSON AVASYS Corporation, SE1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2

Well, it is ! I use SELinux in enable, and in enforcing mode, but after that I switch to permissive and then I reboot, but not work, it stil same problem, and then I switch the SELinux to disable now, and then reboot again, and then I still get the same problem, the problem is /usr/bin/./xsane can detect the scanner sm3600 but not the /usr/local/bin/./xsane , is it so weird ?  I already check /etc/sane.d/dll.conf with sm3600 inside, and then the /usr/local/etc/sane.d/dll.conf also has sm3600 in it but sane-find-scanner cannot find any of it , and also scanimage -L has same problem, cannot fount out any device ? I think I try to re-install fc5 again. to see what happend in here, but sorry I need to ask you this about fc5 problem, do you ever try to add /remove application in fc5 ? it seems weird too, I cannot add or remove my application, everytime I use the add/remove program, it will search information and very long time to take and then it said failed, and then exit the
 program ? haha.. I don't know if fc5 has not stable yet or what. 


How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20060410/88a3476a/attachment.htm

More information about the sane-devel mailing list