[sane-devel] scanner found by sane-find-scanner but not by scanimage -L

Buttay cyril cyril.buttay at free.fr
Mon Dec 4 23:39:17 CET 2006


I don't know if this email is sent to the correct list. Please tell me 
if not.

My problem is as follow:
I have a Snapscan e25 (agfa) on a ubuntu 6.06 machine. This was working 
nice until I add a Samsung printer (ML2010). Apparently, the proprietary 
driver of the printer does some nasty things, including altering the 
sane configuration (in case the printer is a multifunction, which it 
isn't in my case). Since I installed the printer, xsane was working as 
root. I did some googling today, and found that re-installing sane 
solved the problem. I tried, and since then, my scanner is no longer 
found (I reinstalled Snape25.bin as well, and the files in /etc/sane.d 
haven't changed after the reinstall).

Basically, if I run sane-find-scanner, it returns:
found USB scanner (vendor=0x06b9, product=0x4061) at libusb:001:003

if I run scanimage -L (as user or root):
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

SANE_DEBUG_DLL=128 scanimage -L doesn''t mention anything special around 
the snapscan lines:
[dll] init: backend `sp15c' is version 1.0.0
[dll] load: searching backend `snapscan' in `/usr/lib/sane'
[dll] load: trying to load `/usr/lib/sane/libsane-snapscan.so.1'
[dll] load: dlopen()ing `/usr/lib/sane/libsane-snapscan.so.1'
[dll] init: initializing backend `snapscan'
[dll] init: backend `snapscan' is version 1.4.50
[dll] load: searching backend `sm3840' in `/usr/lib/sane'

I also found that it might be better to remove sane completely, to make 
sure there is no conflict between two installs, but there is apparently 
a dependency on "gnome-desktop", so I would prefer not to do this...

I'm a bit lost, because in most of the similar issues that I can found, 
people check the "scanner" module, which apparently is not used anymore 
(and by the way I don't have it)

Any ideas?



More information about the sane-devel mailing list