[sane-devel] Getting scanner to work

Thu Dec 28 12:09:22 CET 2006

Hi all,
I've been told I should post the message below to this list, so here it


-----Original Message-----
Sent: Wednesday, December 27, 2006 9:16 AM
To: 'debian-user at lists.debian.org'
Subject: Getting scanner to work

Hi all,
may I please ask for your help.

I've been given an old scanner by a friend (not sure exactly how old,
but the drivers cd says "windows 95, 98 and NT") and have been trying to
run it from Debian Sarge. It's the first time I plug a scanner into a
Linux box.

After an "apt-get search scanner", I installed sane, then tried to run
xscanimage, but it printed this and exited:

  No scanners were identified. If you were expecting something
  check that the scanner is plugged in, turned on and detected by the
  sane-find-scanner tool (if appropriate). Please read the documentation
  which came with this software (README, FAQ, manpages).

So I tried sane-find-scanner and got this:

    # sane-find-scanner will now attempt to detect your scanner. If the
    # result is different from what you expected, first make sure your
    # scanner is powered up and properly connected to your computer.

    # No SCSI scanners found. If you expected something different, make
sure that
    # you have loaded a SCSI driver for your SCSI adapter.

  found USB scanner (vendor=0x05cb, product=0x1483) at libusb:001:002
    # Your USB scanner was (probably) detected. It may or may not be
supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    # Not checking for parallel port scanners.

    # Most Scanners connected to the parallel port or other proprietary
    # can't be detected by this program.

    # You may want to run this program as root to find all devices. Once
    # found the scanner devices, be sure to adjust access permissions as
    # necessary.

>From the manpages, I found that the scanner device should be called
something like /dev/scanner or /dev/usb/scanner or /dev/sg0, but there's
nothing like that. Here's the output of "ls /dev":

  adsp     hdb      ram10    tty    tty28  tty48  ttyS1   ttyS3   ttyS7
  agpgart  hdc      ram11    tty0   tty29  tty49  ttyS10  ttyS30  ttyS8
  audio    initctl  ram12    tty1   tty3   tty5   ttyS11  ttyS31  ttyS9
  cdrom    input    ram13    tty10  tty30  tty50  ttyS12  ttyS32
  cdrom1   kmem     ram14    tty11  tty31  tty51  ttyS13  ttyS33  vcs
  cdrw     kmsg     ram15    tty12  tty32  tty52  ttyS14  ttyS34  vcs1
  console  log      ram2     tty13  tty33  tty53  ttyS15  ttyS35  vcs2
  core     loop     ram3     tty14  tty34  tty54  ttyS16  ttyS36  vcs3
  dri      MAKEDEV  ram4     tty15  tty35  tty55  ttyS17  ttyS37  vcs4
  dsp      mem      ram5     tty16  tty36  tty56  ttyS18  ttyS38  vcs5
  dvd      mixer    ram6     tty17  tty37  tty57  ttyS19  ttyS39  vcs6
  dvdrw    net      ram7     tty18  tty38  tty58  ttyS2   ttyS4   vcs7
  fd       null     ram8     tty19  tty39  tty59  ttyS20  ttyS40  vcsa
  fd0      port     ram9     tty2   tty4   tty6   ttyS21  ttyS41  vcsa1
  full     ppp      random   tty20  tty40  tty60  ttyS22  ttyS42  vcsa2
  hda      printer  rtc      tty21  tty41  tty61  ttyS23  ttyS43  vcsa3
  hda1     psaux    shm      tty22  tty42  tty62  ttyS24  ttyS44  vcsa4
  hda2     ptmx     snd      tty23  tty43  tty63  ttyS25  ttyS45  vcsa5
  hda5     pts      sndstat  tty24  tty44  tty7   ttyS26  ttyS46  vcsa6
  hda6     radeon   stderr   tty25  tty45  tty8   ttyS27  ttyS47  vcsa7
  hda7     ram0     stdin    tty26  tty46  tty9   ttyS28  ttyS5
  hda8     ram1     stdout   tty27  tty47  ttyS0  ttyS29  ttyS6   zero

I also read that I should load the "sg" kernel module and "a kernel
scanner module": I tried sg, nothing changed. As for the "kernel scanner
module", I don't know how such a module should be called.

Knowing that Sarge may be somewhat outdated with respect to device
support, I've also tried Knoppix (v5.0.1, the latest as far as I know).
But I got exactly the same messages.

The scanner model is: Compeye Simplex 8110U. At least that's what's
written on it, I haven't been given the box nor the manuals, and never
heard about a brand called Compeye.

Can anyone give me some advice? (please Cc: me, I'm not subscribed)

Thanks all

More information about the sane-devel mailing list