[sane-devel] Getting scanner to work

JKD jkdsoft at gmail.com
Thu Dec 28 14:07:47 CET 2006

El Thu, 28 de Dec de 2006, a las 12:09:22PM +0100, BALLABIO GERARDO dijo:
> I've been given an old scanner by a friend (not sure exactly how old,
> but the drivers cd says "windows 95, 98 and NT") and have been trying to
> run it from Debian Sarge. It's the first time I plug a scanner into a
> Linux box.
> After an "apt-get search scanner", I installed sane, then tried to run
> xscanimage, but it printed this and exited:
>   No scanners were identified. If you were expecting something
> different,
>   check that the scanner is plugged in, turned on and detected by the
>   sane-find-scanner tool (if appropriate). Please read the documentation
>   which came with this software (README, FAQ, manpages).
> So I tried sane-find-scanner and got this:
>     # sane-find-scanner will now attempt to detect your scanner. If the
>     # result is different from what you expected, first make sure your
>     # scanner is powered up and properly connected to your computer.
>     # No SCSI scanners found. If you expected something different, make
> sure that
>     # you have loaded a SCSI driver for your SCSI adapter.
>   found USB scanner (vendor=0x05cb, product=0x1483) at libusb:001:002

Your scanner "Compeye Simples 8110U" is not supported:


> >From the manpages, I found that the scanner device should be called
> something like /dev/scanner or /dev/usb/scanner or /dev/sg0, but there's
> nothing like that. Here's the output of "ls /dev":

Since linux kernel 2.6 most of usb devices are managed using libusb, so there
isn't any device node related to usb scanners at /dev. Anyway there isn't any
backend to manage that scanner.

 Jonathan Bravo

More information about the sane-devel mailing list