[sane-devel] Canon Lide 25 not supported?

Steffen Fiedler st.fiedler at freenet.de
Thu Sep 28 00:07:13 UTC 2006


I am trying to get the canon lide 25 scanner to get work with debian (kernel 
2.6.8), it should be supported by plustek-backend.

$> sane-find-scanner

found USB scanner (vendor=0x083a, product=0x4521) at libusb:002:003
found USB scanner (vendor=0x04a9 [Canon], product=0x2220 [CanoScan], 
chip=LM9832/3) at libusb:001:002

Looks good, the first one is an usb-wlan-adapter.

$> scanimage -L
[plustek] usbDev_open(libusb:001:002,0x04A9-0x2220) - (nil)
[plustek] Vendor ID=0x04A9, Product ID=0x2220
[plustek] Device >0x04A9-0x2220<, is not supported!
[plustek] open failed: -1
[plustek] sane_get_devices (0xbfffe998, 0)

I tried the debian-packages and compiling the cvs-snapshot - both times same 
Maybe a conflict with the wlan-adapter? It*s the same error when the 
wlan-adapter is plugged off. 
But if it's plugged in and i try "scanimage -L" the internet-connection hangs 

Thanks & regards,

More information about the sane-devel mailing list