[sane-devel] How do I scan as a normal user?

m. allan noah kitno455 at gmail.com
Sat Apr 26 16:59:25 UTC 2008

man sane-usb

you need to change perms in /proc/bus/usb/ or in  /dev/bus/usb, these
are usually manage by udev.


On 4/25/08, Marc Shapiro <mshapiro_42 at yahoo.com> wrote:
> I recently purchased an EPSON CX7400 All-In-One and it prints and copies
>  great.  Scanning has been a problem.  I am running Debian Etch and have
>  sane and xsane installed.  Until this evening I could not get sane to
>  recognize that I had a scanner installed at all.  I'm not sure what
>  changed that, but it now recognizes the scanner if I run scanimage, or
>  xscanimage as root, but NOT if I run as a normal user.  Running xsane as
>  root gives me warnings that this is not a good idea.  I would much
>  rather run as a normal user.  I have added scanner0 to /dev/.static/dev
>  (that is probably what made it start to work at all) and I have changed
>  its ownership to root:scanner with permissions of 664.  I am in the
>  scanner group, so I expected to be able to use it as non-root.  Do I
>  need to reboot for this to take effect.  What else do I need to do to
>  run xscanimage as non-root?
>  All help will be appreciated.
>  --
>  Marc Shapiro
>  mshapiro_42 at yahoo.com
>  --
>  sane-devel mailing list: sane-devel at lists.alioth.debian.org
>  http://lists.alioth.debian.org/mailman/listinfo/sane-devel
>  Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

"The truth is an offense, but not a sin"

More information about the sane-devel mailing list