[sane-devel] SANE does not recognize my Epson CX-3900 anymore

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Thu Aug 21 23:39:35 UTC 2008

Please send replies to the mailing list as well.

Kanito 73 <kanito73 at hotmail.com> writes:

> Hi
> Thanks for your fast response... well I comment you that something
> strange happens with latest version of SANE, it did not work even as
> 'root', so it was not related to permissions... As a last chance I
> removed latest SANE and reinstalled the previous version just to see
> what happens, and guess what, it worked with previous version!
> latest one does not work with Epson CX3900 for some strange reason.

There is no relevant difference between the epson backends of 1.0.18
and 1.0.19 if you have

  usb 0x04b8 0x082f

in your epson.conf.

> Responding your questions, there are no duplicated installations at
> different paths
>>> usb 0x04b8 0x082f
>>   ^^^^^^^^^^^^^^^^^
>> Is this in your epson.conf?  It should not be necessary.
> So should I remove that line from epson.conf and it will work?

With 1.0.18 you need it, with 1.0.19 you don't because it has been
added to the backend's internal list.

>>> /etc/udev/rules.d/45-libsane.rules:
>>> # Epson CX3900
>>> SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="082f", MODE="664", GROUP="scanner"
>> Does the scanner group exist on your system?  Are you a member of that
>> group?  If not, that might be the problem.
> Yes, it exists with GID=93 (already existing, didn't create it) and
> am part of the group

Please note that you have to be a member of the group at the time you
log in (or explicitly set it with `sg` if you just added yourself and
don't want to log out and back in again).

>> Does your /etc/ld.so.conf include some reference to a lib/sane
>> directory?  It shouldn't.  Remove and run `ldconfig` to fix.
> Nop, it is not included and checked again when I found an article
> mentioning this...
> Finally... My scanner is now working, but have no access as normal
> user, just as root... the 45-libsane.rules is ok, even tried to set
> MODE=0666 but there's no difference :(
> This is just the only problem now, but would like to know why does
> not work the latest SANE but the previous release it does..

What other SANE related bits did you upgrade/change?

Hope this helps,
Olaf Meeuwissen                   FLOSS Engineer -- AVASYS Corporation
FSF Associate Member #1962           sign up at http://member.fsf.org/

More information about the sane-devel mailing list