[sane-devel] Pulstek OpticBook 3800 - problems with openning device on 1.0.23+

Nikolay Shaplov dhyan at nataraj.su
Mon May 13 07:12:11 UTC 2013

> >>       since the ASIC used is a GL845, you should not try forcing it to
> >> 
> >> GL847. They are really different, and nothing will ever work. If you
> >> look at the GL845 datasheet, you'll see it is really close to the GL846.
> >> So close in fact that the same code should be able to run both.
> > 
> > 1. I've build git version with setting GL846 chipset to 3600 clone in the
> > model description. It gives the same result as I wrote before
> > 
> > 2. In 1.0.22 GL847 worked for me well. It stopped working in 1.0.23. So I
> > think this is not an chipset issue. (if at least there were no great
> > changes in genesys_gl847.c)
>      What do you mean by worked well? Since chip a GL845, it won't work
> with GL847 code.

It did not fail on scanner detection, it turn off the light and move the 
scanner head... 
In 1.0.23 it fails on initialization...  Were there great changes in 
genesys_gl847.c between 1.0.22 and 1.0.23?

> In order to test a newly compiled version, you can run it with the
> attached script (edit it to adapt it for the exact location of sane
> sources on your PC).
> The debugging output (preview.pnm and preview.log) will help the
> development and fixes of the backend part for GL846.

Ok. Will do it in several days when I am near the scanner again...

More information about the sane-devel mailing list