[sane-devel] [SOLVED] Re: plustek backend failing to open device under non-root

Yury Tarasievich yury.tarasievich at gmail.com
Sat Sep 12 05:42:55 UTC 2015

Had "one last look" at the problem, which did it. :)

The problem was two-part, and both parts were 
related to the SANE sources/installation.

1) Wrong group ("lp") on scanner device node in 
/dev/bus/usb/... was being set by udev 
libsane.rules installed in /lib/udev/rules.d 
(one of the 2013 daily snapshots judging by the 

So, those guys who were having the same sort of 
problem and "solved" it by (re)installing 
(another version) sane had the solution right, 
in a fashion.

2) Configuring daily snapshot for compilation 
without `--localstatedir=/var` makes the locking 
routines use `/usr/var/lock/sane` sort of path, 
which is of course non-existent.

I'd recommend changing the default value in 
`configure` and possibly also informing the 
operator about the non-existent lock (and 
whatever else) path used in configuration.

Few words on udev rules in the README wouldn't 
hurt, too.

Thanks to all concerned! :)


More information about the sane-devel mailing list