[sane-devel] Need sane docs

Gene Heskett gheskett at shentel.net
Wed May 4 11:20:25 UTC 2016

On Wednesday 04 May 2016 01:43:59 Roger wrote:

> > On Tue, May 03, 2016 at 11:58:56PM -0400, Gene Heskett wrote:
> >That wasn't any help, but since the vendor/product was found when I
> >plugged in a USB cable, running xsane then found it at the usb bus
> > and address, and I ran a few scans.  Seems to work about as expected
> > and I believe at a better color accuracy than the epson NX-515
> > scanner eve produced.  The gamma, brightness and contrast controls
> > seemed to work backwards but they worked and I finally saved a
> > profile of gamma=1.00, brightness and contrast at 0.00 so I'd have a
> > default starting point.
> scanimage seems to have a few bugs, of which I just recently noticed
> scanimage does not appear to reset the device after failure or during
> re-executing scanimage.  XSane will reset the scanning device
> (and/or driver) upon failure.  (*Or* something of this sort,
> as my memory is foggy on the issue and I noticed this bug with
> scanimage more than a week ago, as well as upon previous testing.)
> >But this unit has its usb and ethernet connections on the top, with a
> >molded plastic ditch for cable guidance that leads out the right rear
> > of the top cover, using up 2 feet of cable while still inside the
> > machine, so the 7 port hub its plugged into is now hanging about 18"
> > up in the air with the other 5 cables hanging down from the other
> > face.  hell of a way to run a train.  And the next usb extension
> > cord I have is a 10 meter.
> I think you can use a USB cord up to ~10-15 feet long with the USB 2
> specification.  (I bought a 10-15 foot USB cord ~10 years ago for a
> printer, and now using the 10-15 foot extension with my HP
> multifunction device.)
> And, you can probably buy them far cheaper due to USB 3 being on the
> market.
> Good luck configuring the networking method.  You'll figure it out
> sooner or later.  If you're scanning any thing other than black and
> white documents, such as photographs or negatives, you'll likely find
> the USB method much faster.  As I vaguely recall now from 10+ years
> ago, the scanning was extremely slow using 100mbit.  Hopefully you
> have 1Gbit/1,000mbit.

No, everything here has been setup with 100mbit pieces for about 16 or
17 years.  I think my newest router may do 1000mbit, but the first thing
it sees is a 100mbit 8 port switch, and everything else branches from

That includes a 125 foot run to the old telco hole in the foundation sill,
across under the small back deck, up the house wall to a screw eye in
the edge of the back decks roof, then 50 feet to the peak of the roof
of a 12x16 foot "shop" building, to a 4 port hub which feeds the
computers of 2 CNC controlled machines and when its out there, a lappy
I use at a micro sitdown desk to carve gcode on the rest of the machines
from a sitting position as the machines themselves are operated from a
standing position, very hard on this old farts back full of collapsed

That long piece of Belden Cat5e managed to survive a 112 mph wind in 2010
that took down 3 40 yo pines, all our privacy fence, 50 square feet of
shingles off the roof, a couple shingles off the shop building and flying
debris damaged some siding & guttering.  And the cable still functions
right now.

Knowing what that cable has been through, I haven't a clue why it still
is, but 400 MiB have passed since the lathes box was last rebooted, and
ifconfig says zero errors of any kind.

So this place is wired, but its all 100mbit stuff.  Checking this boards
manual, it says gigabit. So its the external stuff that predates this
board that is the speed limit.  I'll see if I can find a gigabit switch
as a start to upgrading to a gigabit.  That would allow gigabit to this

Back on topic, it seems I cannot run saned as a background daemon, but
I can't find where its disabled.  I found a debug log that apparently
is being generated by saned, and here are the results of the last
attempt to start it:
May  4 00:53:43 coyote saned[21234]: saned (AF-indep+IPv6) from sane-backends 1.0.22 starting up
May  4 00:53:43 coyote saned[21234]: do_bindings: [1] bind failed: Address already in use
May  4 00:53:43 coyote saned[21234]: do_bindings: [0] bind failed: Address already in use
May  4 00:53:43 coyote saned[21234]: do_bindings: couldn't bind an address. Exiting.
May  4 00:53:43 coyote saned[21234]: FATAL ERROR; bailing out, waiting for children...
May  4 00:53:43 coyote saned[21234]: bail_out: all children exited
So thats a very non-informative log. :(  How do I make it tell me what
addresses fail?

Thanks for reading this far.

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

More information about the sane-devel mailing list