[sane-devel] Epson V600 Perfection Scanner

Olaf Meeuwissen paddy-hack at member.fsf.org
Mon Jul 16 06:44:24 BST 2018

Hi Mono,

Monosij Dutta-Roy writes:

> Hello sane-devel -
> My Epson Perfection V600 Flatbed Scanner is not being detected by scanimage
> -L command.
> Also tried with -T (no SANE devices found).
> I am running on Ubuntu 18.04 4 bit.
> Actually it used to be detected under Ub 16.04 - 17.04. I always do a clean
> install of OS and install necessary drivers.
> I clean upgraded to Ubuntu 18.104 and installed gscan2pdf 2.1.0 along with
> the drivers from Epson in file: iscan-gt-x820-bundle-1.0.1.x64.deb:
> http://support.epson.net/linux/en/iscan.php?model=gt-x820&version=1.0.1

So far, so good.  You should have the required DFSG non-free interpreter
module that is needed for this scanner installed.

> Like I always do after a clean install and then use it gscan2pdf.
> All the installation went ok and then gscan2pdf or scanimage -L does not
> detect Epson V600.
> The gscan2pdf folks suggested I check with you so here I am.
> My /etc/sane.d/dll.conf has both epson and epson2 uncommented.

You need the epkowa backend uncommented.  If I remember correctly,
that bundle adds /etc/sane.d/dll.d/epkowa.conf that should take
care of this.

Have you tried as root?  Can you provide the log file produced by

  sudo SANE_DEBUG_DLL=1 SANE_DEBUG_EPKOWA=hex scanimage -L 2>&1 | tee log

If it lists the scanner and mentions the epkowa backend, it's a
permission problem or an issue with the backend not being able to load
the interpreter.  If not, it may be an issue with the bundle's udev

> Would really appreciate your help in getting my scanner working again.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list