[sane-devel] Epson V600 Perfection Scanner

Monosij Dutta-Roy monosij.forums at gmail.com
Mon Jul 16 15:28:48 BST 2018

Hi Olaf -

Thank you for your email. Answers for your questions as follows:

$ sudo SANE_DEBUG_DLL=1 SANE_DEBUG_EPKOWA=hex scanimage -L 2>&1 | tee log
[sanei_debug] Setting debug level of dll to 1.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.27
[dll] load: couldn't find backend `v4l' (No such file or directory)
[dll] load: couldn't find backend `pint' (No such file or directory)
[dll] load: couldn't find backend `epkowa' (No such file or directory)

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

I have the epkowa.conf file installed. But no epkowa backend listed in
dll.conf. As I stated in dll.conf epson and epson2 are uncommented.

$ locate epkowa

I have copied some of the contents of the epkowa.conf in case some aspects
need to be uncommented?

# Detect all devices supported by the backend.
# If you don't have a SCSI device, you can comment out the "scsi"
# keyword.  Similarly for the other keywords.

# For any USB scanner not known to the backend (yet), you may, at your
# own peril(!!), force the backend to recognise and use it via libusb.
# You can do so by the following configuration command:
#   usb <USB vendor ID> <USB product ID>
# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes).  In order
# to find the USB product ID, use lsusb(1).
# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
# which has a product ID of 0x0110, would look as follows:
#usb 0x04b8 0x0110

# For SCSI devices not detected, you can add an entry like:
#   scsi EPSON GT-20000
# where the GT-20000 bit corresponds to the SCSI model information as
# shown in the output of dmesg(1) or in the /var/log/kern.log file.

Hope this is all the info you needed. Please let me know what I should try

Thank you.


On Mon, Jul 16, 2018 at 1:44 AM Olaf Meeuwissen <paddy-hack at member.fsf.org>

> Hi Mono,
> Monosij Dutta-Roy writes:
> > Hello sane-devel -
> >
> > My Epson Perfection V600 Flatbed Scanner is not being detected by
> scanimage
> > -L command.
> > Also tried with -T (no SANE devices found).
> >
> > I am running on Ubuntu 18.04 4 bit.
> >
> > Actually it used to be detected under Ub 16.04 - 17.04. I always do a
> clean
> > install of OS and install necessary drivers.
> >
> > I clean upgraded to Ubuntu 18.104 and installed gscan2pdf 2.1.0 along
> with
> > the drivers from Epson in file: iscan-gt-x820-bundle-1.0.1.x64.deb:
> > http://support.epson.net/linux/en/iscan.php?model=gt-x820&version=1.0.1
> So far, so good.  You should have the required DFSG non-free interpreter
> module that is needed for this scanner installed.
> > Like I always do after a clean install and then use it gscan2pdf.
> >
> > All the installation went ok and then gscan2pdf or scanimage -L does not
> > detect Epson V600.
> >
> > The gscan2pdf folks suggested I check with you so here I am.
> >
> > My /etc/sane.d/dll.conf has both epson and epson2 uncommented.
> You need the epkowa backend uncommented.  If I remember correctly,
> that bundle adds /etc/sane.d/dll.d/epkowa.conf that should take
> care of this.
> Have you tried as root?  Can you provide the log file produced by
>   sudo SANE_DEBUG_DLL=1 SANE_DEBUG_EPKOWA=hex scanimage -L 2>&1 | tee log
> If it lists the scanner and mentions the epkowa backend, it's a
> permission problem or an issue with the backend not being able to load
> the interpreter.  If not, it may be an issue with the bundle's udev
> rules.
> > Would really appreciate your help in getting my scanner working again.
> Hope this helps,
> --
> Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
>  GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
>  Support Free Software                        https://my.fsf.org/donate
>  Join the Free Software Foundation              https://my.fsf.org/join
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20180716/9dbdb189/attachment.html>

More information about the sane-devel mailing list