[sane-devel] Question SANE and Canon Scanner

2bfrank at posteo.de 2bfrank at posteo.de
Tue Aug 25 10:09:00 BST 2020

Dear SANE team,

thanks for a great FOSS project ! Can I bother you with a question, you 
are my last resort, I tried various forums;
regarding the Cannon  LiDE 300 Scanner. I bought it because it is listed 
as "completely supported" in the SANE list 
but I can't get it to work. Here's what I tried:

I am on Linux Mint 20 (Ubuntu 20.04 base), and the scanner is 

Bus 003 Device 004: ID 04a9:1913 Canon, Inc. LiDE 300

scanimage -L
device `pixma:04A91913' is a CANON CanoScan LiDE 300 multi-function

found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at

I found out that it works with sane-pixma,  provided by 
libsane-common_1.0.22-7ubuntu1_amd64 bug
I have 1.0.29 installed, so it should be OK too? According to 
it is provided by the libsane-dev package, so I tried

sudo apt install libsane-dev
still no result...

simple scan output:

simple-scan -d (debug mode)
+9,45s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+9,45s] DEBUG: scanner.vala:353: Device: name="pixma:04A91913"
vendor="CANON" model="CanoScan LiDE 300" type="multi-function 
[+9,45s] DEBUG: scanner.vala:353: Device:
name="escl:" vendor="ESCL" model="LiDE 300 HTTP"
type="flatbed scanner"
[+13,68s] DEBUG: simple-scan.vala:455: Requesting scan at 300 dpi from
device 'pixma:04A91913'
[+13,68s] DEBUG: scanner.vala:1676: Scanner.scan ("pixma:04A91913",
dpi=300, scan_mode=ScanMode.COLOR, depth=8, type=single, paper_width=0,
paper_height=0, brightness=0, contrast=0, delay=3000ms)
[+13,68s] DEBUG: scanner.vala:828: Processing request
[+14,20s] DEBUG: scanner.vala:889: sane_open ("pixma:04A91913") ->
[+14,20s] WARNING: scanner.vala:893: Unable to open device: Device busy

XSane says the same thing. Unable to open device: Device busy

here's what dmesg said:

41353.742838] usb 1-3: new high-speed USB device number 5 using xhci_hcd
[41353.804289] usb 1-3: New USB device found, idVendor=04a9,
idProduct=1913, bcdDevice= 1.00
[41353.804292] usb 1-3: New USB device strings: Mfr=1, Product=2,
[41353.804295] usb 1-3: Product: LiDE 300
[41353.804297] usb 1-3: Manufacturer: Canon
[41353.804298] usb 1-3: SerialNumber: 486D04
[41353.864304] usb 1-3: usbfs: process 20985 (ippusbxd) did not claim
interface 0 before use
[41353.906525] audit: type=1400 audit(1598002277.392:90):
apparmor="DENIED" operation="open" profile="ippusbxd"
name="/etc/nsswitch.conf" pid=21004 comm="ippusbxd" requested_mask="r"
denied_mask="r" fsuid=0 ouid=0

I found in a forum that ippusbxd might be the problem, removed the 
package, but no result.

I also manually added line in file /etc/sane.d/genesys.conf and
# Canon LIDE 300
usb 0x04a9 0x1913

as well as in
# Canon LIDE
ATTRS{type}=="3", ATTRS{vendor}=="04a9", ATTRS{model}=="1913",

I'm really sorry to use you as a hotline, but if there are any ideas, I 
would be grateful;
All the Best

More information about the sane-devel mailing list