[sane-devel] Plustek OpticSlim 2610 scanner issues

Md. Rakib Hossain Khan Abir rakib.abir at gmail.com
Sun Feb 9 19:01:17 GMT 2020


I checked the sane-project and didn't find plustek opticslim 2610 to be listed. Hence I tried to detect the scanner using-

sudo sane-find-scanner -q

found USB scanner (vendor=0x07b3, product=0x047e [1200dpi USB Scanner], chip=GT-6816) at libusb:002:004

Then I downloaded the windows driver package from Plustek website and found cis3R5B1.fw (Plustek OpticSlim 2400 also has a firmware with the same name according to gt68xx backend page!!).


sudo cp cis3R5B1.fw /usr/share/sane/gt68xx/
sudo chmod a+r /usr/share/sane/gt68xx/cis3R5B1.fw

Then I changed the /etc/sane.d/gt68xx.conf by adding the following-

usb 0x07b3 0x047e
override "plustek-opticslim-2400"
firmware "/usr/share/sane/gt68xx/cis3R5B1.fw"
vendor "Plustek"
model "Plustek OpticSlim 2610"

The above steps, made me enable to use the scanner but only with root privileges which I managed to overcome by-

sudo gpasswd -a abir scanner

sudo cp /usr/lib64/udev/rules.d/49-sane.rules /etc/udev/rules.d

and I also commented all entries except gt68xx and plustek on /etc/sane.d/dll.conf

The permission problem resolved after these steps.

Now, the issues with the scanner are-

1. It scans with wrong colors. White papers are displayed as yellowish. On checking the RGB channels on gimp blue channel is present but blank. Turning on/off the blue channel doesn't bring any change to the image. But the scanner works fine on Windows 10 on virtualbox.

2. Exact scanner model is not displayed neither on the terminal nor on the titlebar of frontends (I used skanlite and xsane). If I remove model from gt68xx.conf then plustek opticslim 2400 is displayed.

3. It works relatively slow compared to windows.

4. The previews of frontends also don't work properly, show horizontal bars.

5. Scanner performs limited with only 600 and 1200 dpi (tried all dpi only in 8 bit mode). Lower dpi don't work, unusable images are generated.

6. When performed at 1200 dpi, at the end scanner produces a cracking sound.

7. B&W images are produced only through green channel. Red shows completely black and blue white.

So, I would like feedback regarding my steps (including obtaining root privileges).

The scanner works upto 12 bit 1200 dpi which are provided on the frontends.

I am using manjaro KDE on kernel 5.4.17-1 lts. I am new to linux, so this is the best I can provide right now.

If possible, please add support to the scanner in the backend.

With regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20200209/74b01487/attachment.html>

More information about the sane-devel mailing list