[sane-devel] Fwd: unable to read device-id

Olaf Meeuwissen paddy-hack at member.fsf.org
Wed Jun 10 11:02:11 BST 2020

Hi Miguel,

Miguel Silva writes:

> Sorry about my delay,

Same here :-/

> See my answers below.
> Em seg., 25 de mai. de 2020 às 09:07, Olaf Meeuwissen <
> paddy-hack at member.fsf.org> escreveu:
>> Hi Miguel,
>> Miguel Silva writes:
>> > Hi there,
>> >
>> > I need a help to try fix my scan.
>> >
>> > In the begin i was capable to scan but something wrong happened.
>> >
>> > Now i can use the scan only out of gnome. I exit the session (logout) and
>> > enter in text mode (ALT + F2) and then i use:
>> >
>> >    scanimage -x 100 -y 100 --format=jpeg > image.jpg
>> >
>> > It's work!
>> Did you run that as root or as a regular user?
> [Miguel] - yes, i tried to run as root and the result was the same.

So there's no permission issue.  Good.

>> [...]
>> > But in the gnome the scanner didn't work.
>> Could you be a bit more specific?  What application did you use?  How
>> did it not work?  As in, what did you expect to happen and what actually
>> happened.
> [Miguel] - I tried with 'iscan' and  'scanimage'. The result is nothing and
> looking the LOG appear this:
> mai 20 11:54:10 megs-fedora iscan[6547]: io/hpmud/pp.c 627: unable to read
> device-id ret=-1

That source code file is not part of iscan or the epkowa backend.  Looks
like you have some HP software installed that triggers this log message.
I don't think it is relevant to your problem.  Perhaps you should ask
around on the Fedora forums.

If you don't use any HP hardware, you could uninstall whatever packages
cater to HP hardware to see if that fixes things.  On my Debian-based
system the packages to look for would be


On Fedora package names will be slightly different but I guess you get
the picture.  Actually, I think that libsane-hpaio is the cause of that
log message you posted.

> [Miguel] - I expect to scan the paper that i put in the scan.
>> I attached some information about my system and the error message.
>> Thanks.  I gather that you are using the third-party epkowa backend with
>> a non-free binary-only plugin to scan with this device.
>> > My distro is Fedora 32 and i use Xorg because i couldn't compile my video
>> > driver.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list