[sane-devel] Canon LiDE 700F not working with sane-backends 1.0.29

Povilas Kanapickas povilas at radix.lt
Mon Mar 9 16:45:10 GMT 2020


On 3/8/20 6:23 PM, Ralph Little wrote:
> Hi,
> On 2020-03-08 7:23 a.m., Bit Juggler wrote:
>> Dear list readers,
>> i have a Canon LiDE 700F flatbed scanner connected via USB to an
>> USB3.0-port of my machine.
>> My machine runs openSUSE Tumbleweed with
>> Kernel 5.5.7-1-default
>> sane-backends 1.0.29-1.1
>> libsane1 1.0.29-1.1
>> xsane 0.999-2.10
>> Using sane-backends 1.0.27. scanning worked fine but last week i
>> received an update to sane-backends 1.0.29 and scanning does not work
>> any longer.
>> When i use xsane and do a preview i can see the page being build up but
>> at the end when the scanner has been moved back to its start position
>> the preview gets deleted and xsane gives an device-I/O-error.
> It was noticed that the support for 700F is broken at the moment.
> There is a current issue on GitLab, tracking this:
> https://gitlab.com/sane-project/backends/-/issues/246
> Povilas, do you have a feeling that this might be something useful for
> me to look into, or is it something that would be best left to you?
> Cheers,
> Ralph

If it worked before, then it's likely a bug I introduced. I'd like to
investigate and fix it myself so that I'm aware of what exact assumption
I made that turned out to be invalid.


More information about the sane-devel mailing list