[Nut-upsuser] two MGE Ellipse 1500 ups via usb

Thomas Gutzler thomas.gutzler at gmail.com
Sun Nov 15 13:18:49 UTC 2009


I've got two MGE Ellipse 1500 UPS connected via usb to an ubuntu
jaunty system with nut and libupsclient1 2.4.1-2ubuntu4.
As soon as I start the driver for the second one, they start fighting
each other and I get no data. I found an older post to this list that
said: If you want to monitor multiple UPSes through usbhid-ups, you
*must* make sure that each one can be uniquely identified through the
"vendor", "product", "serial", "vendorid", "productid" and "bus"
regular expressions (see 'man 8 usbhid-ups' for an explanation how to
use these).
So I ran lsusb -v and got two different values for iSerial (1HCG4700J
and 000000000) and iManufacturer ('1 MGE UPS SYSTEMS' and '1 EATON').
Strangely, vendor is '0x0463 MGE UPS Systems' for both.
They're also on the same bus ('Bus 003 Device 063' and 'Bus 003 Device 064')
Since there is no flag for manufacturer, I had to go with serial. This
is my new ups.conf:
       driver = usbhid-ups
       port = /dev/usb/hiddev0
       driver = usbhid-ups
       port = /dev/usb/hiddev1
When I run upsdrvctl start ups1, it starts /lib/nut/usbhid-ups -a ups1
but no -x flag.

Starting usbhid-ups manually with the -x serial=000000000 and -DD flag shows:
Checking device (0463/FFFF) (003/064)
- VendorID: 0463
- ProductID: ffff
- Manufacturer: MGE UPS SYSTEMS
- Product: ELLIPSE
- Serial Number: 1HCG4700J
- Bus: 003
Trying to match device
Device does not match - skipping
Checking device (0463/FFFF) (003/063)
- VendorID: 0463
- ProductID: ffff
- Manufacturer: EATON
- Product: ELLIPSE
- Serial Number: 000000000
- Bus: 003
Trying to match device
Device matches

so it seems to be working. But how can I get upsdrvctl to add the -x
flag automatically?


More information about the Nut-upsuser mailing list