[Nut-upsuser] bcmxcp_usb can not communicate with Eaton Powerware 5110

Greg Vickers daehenoc at iinet.net.au
Sun Aug 12 02:11:06 UTC 2012

On 11/08/12 06:58, Arnaud Quette wrote:
> Hi Massimo and Greg,
> @Greg: if you yet returned your unit, you now have a solution ;)
I have not yet gotten rid of it, so thank you very much!  It's a case of 
download, extract, apply patch, and compile on my RPi, correct?
> thanks for the effort for the patch!
> welcome ;)
>     > I took most of this afternoon looking at this issue, and this
>     should be
>     > fixed with the attached patch
>     > It applies fine on 2.6.5, using the following command:
>     > # cd nut-2.6.5
>     > # patch -p0 < /path/to/xcp-rcv-loop.diff
>     > # make
>     >
>     > I've tested it on a 5110 only currently, so it's not applied to the
>     > development tree.
>     > for testing purpose, I've also used a byte frame size, to be in your
>     > condition (Ie, set the 4th param of usb_interrupt_read() to '8').
>     >
>     > please tell me back how it behave on RPi.
>     > note that I'll probably have to do some code adjustment, and
>     obviously
>     > regression testing on other units, before committing the patch
>     to the main
>     > source tree.
>     >
>     I applied your patch to the 2.6.5 code and run only the bcmxcp_usb
>     driver and... I'm not sure that everything is ok.
> sorry, I forgot to explicitly request the trace (debug level 5) to 
> validate on my side...
>     If I run the driver as "./bcmxcp_usb -u root -a ups" it launches, but
>     after a second I get a "Communications with UPS lost: get_answer: not
>     the right sequence received 0!!!". However the driver seems still to
>     keep running.
>     I also tried to start the driver under debug (-DDDD). In attachment
>     you can see the output (until I typed ctrl-c), that also include some
>     some of the 'communication lost' messages.
> the driver runs fine. you should get a good upsc output now.
> the "Comm lost" msg are part of code adjustments needed, but the code 
> already handle this fine, and recovers (check "entering 
> get_answer(33)" for example).
> could you please confirm this by sending the upsc output, and starting 
> upsmon to monitor on the RPi?
I'll let you know how I go!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20120812/900d0269/attachment.html>

More information about the Nut-upsuser mailing list