[pymvpa] Issues installing the libsvm wrapper

Yaroslav Halchenko debian at onerussian.com
Wed Mar 7 15:28:03 UTC 2012

looks like a good old failure due to old swig

try with the ones I have pre-generated from
placed under mvpa2/clfs/libsvmc

NB now testing with up-to-date swig 2.0.4


> Hi

> I am helping a colleague in installing PyMVPA on a Linux CentOS
> - where the libraries/software are not very updated. So we started manually
> installing Python2.7, NumPy1.6.1, SciPy0.10, Matplotlib1.1, nibabel and
> all went well. We had the following issue while installing PyMVPA,
> specifically on the libsvm wrapper part. Following doc/source/installation.rst
> we did "make 3rd" and then "python setup.py build_ext" but the
> second one failed on libsvm_wrap.cpp as reported below. Could it be
> that the g++ compiler is a bit too old (g++ v4.1)? We tried also
> "python setup.py build_ext --with-libsvm" with the same result.
> Note that libsvm was not already installed on the system so we want
> to use the one shipped with PyMVPA.

> By the way we are using the latest tarball of PyMVPA from GitHub.

> Best,

> Emnauele
Keep in touch                                     www.onerussian.com
Yaroslav Halchenko                 www.ohloh.net/accounts/yarikoptic

More information about the Pkg-ExpPsy-PyMVPA mailing list