[pymvpa] Windows executable? for mvpa2

Yaroslav Halchenko debian at onerussian.com
Wed Mar 21 14:08:43 UTC 2012

Hi Jenn,

Sorry about your problems -- indeed we haven't been paying adequate
attention to Windows build because even if that one succeeds we consider
that environment somewhat suboptimal to fully enjoy PyMVPA in tandem
with other tools needed for research.  We have been recommended (with
only good feedback from those who tried) to use NeuroDebian virtual
in a matter of minutes you should be able to start using PyMVPA or any
other software (from >30,000 of available).

Meanwhile --  I have uploaded pymvpa2-2.0.0.win32-py2.6.exe we have
built in Dec 2011 to
NB sorry -- there have been a problem with alioth's file release module,
   for some reason uploaded materials do not appear online and we had
   no time to address it.

Alternatively you might like to try installers from the unofficial
collection of Python modules by Christoph Gohlke:

Hope this helps

On Wed, 21 Mar 2012, Jenn Olejarczyk wrote:

>    Hi,
>    � �I tried to go through all the steps for making the PyMVPA work for
>    windows but I guess one of my steps might be wrong. �The steps are below
>    with some questions if someone know what I did wrong....
>    STEP 1: got MinGW, added to the path for both C:\MinGW and C:\MinGW\bin
>    STEP 2: got the swigwin, ran the executable
>    STEP 3: changed setup.cfg.win to setup.cfg
>    STEP 4: checked the Makefile.win so it has the right path
>    -> I have Python 2.6 and the path was set to 'C:\\Python26'. �Will this
>    still work? �I am just not familiar with the double backslash
>    STEP 5:�mingw32-make -f Makefile.win installer
>    -> so I tried this at the Run cmd line, made sure the MinGW, Python, and
>    PyMVPA were all in the environment path. �Was this the right thing to do?
>    I don't see any executables in PyMVPA folder or site-packages for mvpa2 in
>    the Python directory. �I've had the other packages install fine from
>    executables but making my own has been an issue. �I tried opening the
>    setup.py file as well in PyMVPA and running that then selecting the
>    compile and build options. �I get a build folder but no executables. �Any
>    one know what I am doing wrong or have an executable that works for the
>    updated PyMVPA? �I found an executable from March 2011
>    (pymvpa-0.6.0~rc3.win32-py2.6) but it didn't have mvpa2 rather just mvpa.
>    Any suggestions or solutions?
>    Thanks for the help,
>    Jenn�

> _______________________________________________
> Pkg-ExpPsy-PyMVPA mailing list
> Pkg-ExpPsy-PyMVPA at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-exppsy-pymvpa

Keep in touch                                     www.onerussian.com
Yaroslav Halchenko                 www.ohloh.net/accounts/yarikoptic

More information about the Pkg-ExpPsy-PyMVPA mailing list