[pkg-go] Bug#1020288: debos: unable to resolve host address

Diederik de Haas didi.debian at cknow.org
Thu Nov 17 09:44:16 GMT 2022

Control: reopen -1 
Control: found -1 1.1.1-2

On Mon, 19 Sep 2022 18:09:44 +0700 Arnaud Rebillout <arnaudr at kali.org> wrote:
> at the moment debos (and fakemachine) is broken in unstable:

And it's still broken, but now also in Testing

I installed debos, but without systemd-resolved:

root at prancing-pony:~# aptitude install debos systemd-resolved=
The following NEW packages will be installed:
  bmap-tools{a} debos ipxe-qemu{a} libbpf0{a} libbrlapi0.8{a} libcacard0{a} 
libcapstone4{a} libdaxctl1{a} libexecs0{a} libfdt1{a} libndctl6{a} libnss-
  libostree-1-1{a} libpmem1{a} libslirp0{a} libspice-server1{a} 
libusbredirparser1{a} libvdeplug2{a} libvirglrenderer1{a} libvte-2.91-0{a} 
  ovmf{a} qemu-system-common{a} qemu-system-data{a} qemu-system-gui{a} qemu-
system-x86{a} seabios{a} systemd-container{a} 
The following packages are RECOMMENDED but will NOT be installed:

Then tried it

$ sudo debos debos-recipes/debian-quartz64a.yaml 
[sudo] password for diederik: 
Running /debos --artifactdir /home/diederik/dev/github/cp-quartz64-images /
quartz64a.yaml --internal-image /dev/disk/by-fakemachine-label/fakedisk-0 
using kvm backend
2022/11/17 09:31:13 ==== recipe ====
2022/11/17 09:31:13 ==== debootstrap ====
2022/11/17 09:31:14 Debootstrap | I: Retrieving InRelease 
2022/11/17 09:31:14 Debootstrap | I: Retrieving Release 
2022/11/17 09:31:14 Debootstrap | E: Failed getting release file https://
2022/11/17 09:31:14 debootstrap.log | wget: unable to resolve host address 
2022/11/17 09:31:14 debootstrap.log | wget: unable to resolve host address 
2022/11/17 09:31:14 Action `recipe` failed at stage Run, error: exit status 1
2022/11/17 09:31:14 Warning: Failed to get unmount /: invalid argument
2022/11/17 09:31:14 Unmount failure can cause images being incomplete!
Powering off.

FWIW: Exact same result without sudo

diederik at prancing-pony:~/dev/github/cp-quartz64-images$ ping deb.debian.org
PING debian.map.fastlydns.net ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=57 time=20.7 ms
64 bytes from ( icmp_seq=2 ttl=57 time=23.4 ms
--- debian.map.fastlydns.net ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 20.686/22.025/23.364/1.339 ms

So my system has no problem with resolving addresses, but debos does when 
systemd-resolved is NOT installed.
So it looks to me it should be a hard Dependency, not a Recommends.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: This is a digitally signed message part.
URL: <http://alioth-lists.debian.net/pipermail/pkg-go-maintainers/attachments/20221117/4fc2b037/attachment.sig>

More information about the Pkg-go-maintainers mailing list