[sane-devel] Microtek SlimScan C3, output always a black image

Jose Sanchez joseos@okstate.edu
Thu, 12 Jun 2003 18:23:22 -0700

Hi Karsten, thanks for the help and the time you have put in this.  I 
have only a question, the thing is that I my SUSE distribution I have 
libsane-microtek2.so.1.0.11 instead of the libsane-microtek2.so.1.0.9. 
 I tried replacing it but the scanner program doesn't even start.  So, I 
made the following:  I uninstall the sane package that came with SUSE 
and I downloaded one from the sane webpage 1.0.12 (I think is the last 
one).  Can I replace the .c and .h with the one that you posted in your 
web page with this distribution of sane or should I download an older 
distribution.  If so I will continue and see what happends.



Karsten Festag wrote:

>Hi Jose,
>ok, I think I found and solved the problem. I put the changed code on my 
>homepage www.karstenfestag.gmxhome.de, it's the latest version. You will have 
>to remove the SUSE packages and compile SANE from the sources if you want to 
>use that.
>But I think you can try to exchange only the library file so you don't have to 
>uninstall the SUSE package and compile SANE by yourself: for this you have to 
>find the file 'libsane-microtek2.so.1.0.9'; I think it is in /usr/lib/sane or 
>/usr/local/lib/sane. This file is linked to libsane-microtek2.so.1 and 
>Please remove the links (all these things are to be done as root) and replace 
>the libsane-microtek2.so.1.0.9 file with the one I attached to this mail 
>(don't forget to unpack (bunzip) the attached file :-) )
>The re-create the links:
>ln libsane-microtek2.so.1.0.9 libsane-microtek2.so.1
>ln libsane-microtek2.so.1.0.9 libsane-microtek2.so
>( of course to be typed in the directory where the libsane-microtek2.so.1.0.9 
>file is)
>Have luck!
>[ this is a copied mail for the list without attachment ]
>Sane-devel mailing list